summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbionade242020-12-10 18:49:25 +0100
committerbionade242020-12-10 18:49:25 +0100
commit6594310e6a9ede9bff06485a2b7c727fa33473f9 (patch)
tree84b9ca217f503182045617f007065072a14b5cba
parent0ef5673e92f6d2afce12d7bec9bfad5ca4fad007 (diff)
downloadaur-6594310e6a9ede9bff06485a2b7c727fa33473f9.tar.gz
Install boost version to opt/
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD38
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09c69868c5d9..30a46aa3f13f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = boost1.69
pkgver = 1.69.0
- pkgrel = 5
+ pkgrel = 6
url = https://www.boost.org/
arch = i686
arch = x86_64
@@ -29,6 +29,6 @@ pkgname = boost1.69
pkgdesc = Free peer-reviewed portable C++ source libraries - development headers
depends = boost1.69-libs=1.69.0
optdepends = python: for python bindings
- conflicts = boost
+ conflicts =
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index 646abc18dee9..7dd57422f7c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,12 +14,12 @@ pkgbase=boost1.69
pkgname=('boost1.69-libs' 'boost1.69')
pkgver=1.69.0
_boostver=${pkgver//./_}
-pkgrel=5
+pkgrel=6
url='https://www.boost.org/'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
license=('custom')
makedepends=('icu' 'python' 'python-numpy' 'bzip2' 'zlib' 'openmpi')
-source=(https://downloads.sourceforge.net/project/boost/boost/${pkgver}/boost_${_boostver}.tar.bz2)
+source=("https://downloads.sourceforge.net/project/boost/boost/${pkgver}/boost_${_boostver}.tar.bz2")
sha256sums=('8f32d4617390d1c2d16f26a27ab60d97807b35440d45891fa340fc2648b04406')
# ************************************************************************* #
@@ -32,7 +32,7 @@ build() {
cd boost_${_boostver}
- ./bootstrap.sh --with-toolset=gcc --with-icu --with-python=/usr/bin/python3
+ ./bootstrap.sh --with-toolset=gcc --with-icu --with-python=/opt/boost1.69/bin/python3
_bindir="bin.linuxx86"
[[ "${CARCH}" = "x86_64" ]] && _bindir="bin.linuxx86_64"
@@ -67,21 +67,21 @@ build() {
package_boost1.69() {
pkgdesc='Free peer-reviewed portable C++ source libraries - development headers'
depends=("boost1.69-libs=${pkgver}")
- conflicts=('boost')
+ conflicts=()
optdepends=('python: for python bindings')
options=('staticlibs')
- install -dm755 "${pkgdir}"/usr
- cp -a "${_stagedir}"/{bin,include,share} "${pkgdir}"/usr
+ install -dm755 "${pkgdir}"/opt/boost1.69
+ cp -a "${_stagedir}"/{bin,include,share} "${pkgdir}"/opt/boost1.69
- install -d "${pkgdir}"/usr/lib
- cp -a "${_stagedir}"/lib/*.a "${pkgdir}"/usr/lib/
- cp -a "${_stagedir}"/lib/libboost_*.so "${pkgdir}"/usr/lib/
+ install -d "${pkgdir}"/opt/boost1.69/lib
+ cp -a "${_stagedir}"/lib/*.a "${pkgdir}"/opt/boost1.69/lib/
+ cp -a "${_stagedir}"/lib/libboost_*.so "${pkgdir}"/opt/boost1.69/lib/
install -Dm644 "${srcdir}/"boost_${_boostver}/LICENSE_1_0.txt \
- "${pkgdir}"/usr/share/licenses/boost1.69/LICENSE_1_0.txt
+ "${pkgdir}"/opt/boost1.69/share/licenses/boost1.69/LICENSE_1_0.txt
- ln -s /usr/bin/b2 "$pkgdir"/usr/bin/bjam
+ ln -s /opt/boost1.69/bin/b2 "$pkgdir"/opt/boost1.69/bin/bjam
}
package_boost1.69-libs() {
@@ -90,18 +90,18 @@ package_boost1.69-libs() {
optdepends=('openmpi: for mpi support')
provides=('libboost_context.so')
- install -dm755 "${pkgdir}"/usr
- cp -a "${_stagedir}"/lib "${pkgdir}"/usr
- rm "${pkgdir}"/usr/lib/*.a
+ install -dm755 "${pkgdir}"/opt/boost1.69
+ cp -a "${_stagedir}"/lib "${pkgdir}"/opt/boost1.69
+ rm "${pkgdir}"/opt/boost1.69/lib/*.a
# remove library symlinks shipped in boost1.69 / conflicting with boost-libs
- rm "${pkgdir}"/usr/lib/libboost_*.so
-
- # remove mpi.so module which conflicts with boost
- rm "${pkgdir}"/usr/lib/mpi.so
+ rm "${pkgdir}"/opt/boost1.69/lib/libboost_*.so
install -Dm644 "${srcdir}/"boost_${_boostver}/LICENSE_1_0.txt \
- "${pkgdir}"/usr/share/licenses/boost1.69-libs/LICENSE_1_0.txt
+ "${pkgdir}"/opt/boost1.69/share/licenses/boost1.69-libs/LICENSE_1_0.txt
+
+ mkdir -p "${pkgdir}"/etc/ld.so.conf.d
+ echo "/opt/boost1.69/lib" > "${pkgdir}"/etc/ld.so.conf.d/boost1.69.conf
}
# vim: ts=2 sw=2 et: