summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvangelos Foutras2020-02-23 00:14:11 +0200
committerEvangelos Foutras2020-02-23 00:14:11 +0200
commitd1081b2c31b6fe8a68d11219d58d16829cd6b8a2 (patch)
treed71e8229ef0307f687e3f71f7c0870c3132acbc5
downloadaur-d1081b2c31b6fe8a68d11219d58d16829cd6b8a2.tar.gz
Move from [extra] as some AUR packages use this
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD142
2 files changed, 175 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95dacbf7c250
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = boost1.69
+ pkgver = 1.69.0
+ pkgrel = 4
+ url = https://www.boost.org/
+ arch = x86_64
+ license = custom
+ makedepends = icu
+ makedepends = python
+ makedepends = python2
+ makedepends = python-numpy
+ makedepends = python2-numpy
+ makedepends = bzip2
+ makedepends = zlib
+ makedepends = openmpi
+ source = https://downloads.sourceforge.net/project/boost/boost/1.69.0/boost_1_69_0.tar.bz2
+ sha256sums = 8f32d4617390d1c2d16f26a27ab60d97807b35440d45891fa340fc2648b04406
+
+pkgname = boost1.69-libs
+ pkgdesc = Free peer-reviewed portable C++ source libraries - runtime libraries
+ depends = bzip2
+ depends = zlib
+ depends = icu
+ optdepends = openmpi: for mpi support
+ provides = libboost_context.so
+
+pkgname = boost1.69
+ pkgdesc = Free peer-reviewed portable C++ source libraries - development headers
+ depends = boost1.69-libs=1.69.0
+ optdepends = python: for python bindings
+ optdepends = python2: for python2 bindings
+ conflicts = boost
+ options = staticlibs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2675926ca88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,142 @@
+# Maintainer:
+# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Marius Knaust <marius.knaust@gmail.com>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: kevin <kevin@archlinux.org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Kritoke <kritoke@gamebox.net>
+# Contributor: Luca Roccia <little_rock@users.sourceforge.net>
+
+pkgbase=boost1.69
+pkgname=('boost1.69-libs' 'boost1.69')
+pkgver=1.69.0
+_boostver=${pkgver//./_}
+pkgrel=4
+url='https://www.boost.org/'
+arch=('x86_64')
+license=('custom')
+makedepends=('icu' 'python' 'python2' 'python-numpy' 'python2-numpy' 'bzip2' 'zlib' 'openmpi')
+source=(https://downloads.sourceforge.net/project/boost/boost/${pkgver}/boost_${_boostver}.tar.bz2)
+sha256sums=('8f32d4617390d1c2d16f26a27ab60d97807b35440d45891fa340fc2648b04406')
+
+# ************************************************************************* #
+# Temporary package added for building mapnik; should NOT be used elsewhere #
+# ************************************************************************* #
+
+build() {
+ export _stagedir="${srcdir}/stagedir"
+ local JOBS="$(sed -e 's/.*\(-j *[0-9]\+\).*/\1/' <<< ${MAKEFLAGS})"
+
+ cd boost_${_boostver}
+
+ ./bootstrap.sh --with-toolset=gcc --with-icu --with-python=/usr/bin/python2
+
+ _bindir="bin.linuxx86"
+ [[ "${CARCH}" = "x86_64" ]] && _bindir="bin.linuxx86_64"
+ install -Dm755 tools/build/src/engine/$_bindir/b2 "${_stagedir}"/bin/b2
+
+ # Support for OpenMPI
+ echo "using mpi ;" >> project-config.jam
+
+ # boostbook is needed by quickbook
+ install -dm755 "${_stagedir}"/share/boostbook
+ cp -a tools/boostbook/{xsl,dtd} "${_stagedir}"/share/boostbook/
+
+ # default "minimal" install: "release link=shared,static
+ # runtime-link=shared threading=single,multi"
+ # --layout=tagged will add the "-mt" suffix for multithreaded libraries
+ # and installs includes in /usr/include/boost.
+ # --layout=system no longer adds the -mt suffix for multi-threaded libs.
+ # install to ${_stagedir} in preparation for split packaging
+ "${_stagedir}"/bin/b2 \
+ variant=release \
+ debug-symbols=off \
+ threading=multi \
+ runtime-link=shared \
+ link=shared,static \
+ toolset=gcc \
+ python=2.7 \
+ cflags="${CPPFLAGS} ${CFLAGS} -fPIC -O3" \
+ cxxflags="${CPPFLAGS} ${CXXFLAGS} -std=c++14 -fPIC -O3" \
+ linkflags="${LDFLAGS}" \
+ --layout=system \
+ ${JOBS} \
+ \
+ --prefix="${_stagedir}" \
+ install
+
+ # because b2 in boost 1.62.0 doesn't seem to respect python parameter, we
+ # need another run for liboost_python3.so
+
+ ./bootstrap.sh --with-toolset=gcc --with-icu --with-python=/usr/bin/python3 \
+ --with-libraries=python
+
+ "${_stagedir}"/bin/b2 clean
+ "${_stagedir}"/bin/b2 \
+ variant=release \
+ debug-symbols=off \
+ threading=multi \
+ runtime-link=shared \
+ link=shared,static \
+ toolset=gcc \
+ python=3.8 \
+ cflags="${CPPFLAGS} ${CFLAGS} -fPIC -O3" \
+ cxxflags="${CPPFLAGS} ${CXXFLAGS} -std=c++14 -fPIC -O3" \
+ linkflags="${LDFLAGS}" \
+ --layout=system \
+ ${JOBS} \
+ \
+ --prefix="${_stagedir}/python3" \
+ --with-python \
+ install
+}
+
+package_boost1.69() {
+ pkgdesc='Free peer-reviewed portable C++ source libraries - development headers'
+ depends=("boost1.69-libs=${pkgver}")
+ conflicts=('boost')
+ optdepends=('python: for python bindings'
+ 'python2: for python2 bindings')
+ options=('staticlibs')
+
+ install -dm755 "${pkgdir}"/usr
+ cp -a "${_stagedir}"/{bin,include,share} "${pkgdir}"/usr
+
+ install -d "${pkgdir}"/usr/lib
+ cp -a "${_stagedir}"/lib/*.a "${pkgdir}"/usr/lib/
+ cp -a "${_stagedir}"/lib/libboost_*.so "${pkgdir}"/usr/lib/
+
+ install -Dm644 "${srcdir}/"boost_${_boostver}/LICENSE_1_0.txt \
+ "${pkgdir}"/usr/share/licenses/boost1.69/LICENSE_1_0.txt
+
+ install -Dm644 "${_stagedir}"/python3/lib/libboost_*.a \
+ "${pkgdir}"/usr/lib/
+
+ ln -s /usr/bin/b2 "$pkgdir"/usr/bin/bjam
+}
+
+package_boost1.69-libs() {
+ pkgdesc='Free peer-reviewed portable C++ source libraries - runtime libraries'
+ depends=('bzip2' 'zlib' 'icu')
+ optdepends=('openmpi: for mpi support')
+ provides=('libboost_context.so')
+
+ install -dm755 "${pkgdir}"/usr
+ cp -a "${_stagedir}"/lib "${pkgdir}"/usr
+ cp -a "${_stagedir}"/python3/lib/libboost_* "${pkgdir}"/usr/lib
+ rm "${pkgdir}"/usr/lib/*.a
+
+ # remove library symlinks shipped in boost1.69 / conflicting with boost-libs
+ rm "${pkgdir}"/usr/lib/libboost_*.so
+
+ # remove mpi.so module which conflicts with boost
+ rm "${pkgdir}"/usr/lib/mpi.so
+
+ install -Dm644 "${srcdir}/"boost_${_boostver}/LICENSE_1_0.txt \
+ "${pkgdir}"/usr/share/licenses/boost1.69-libs/LICENSE_1_0.txt
+}
+
+# vim: ts=2 sw=2 et: