summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornbebaw2021-01-22 13:11:32 +0100
committernbebaw2021-01-22 13:11:32 +0100
commit06b2ba3b4bf46a952e8f83592e8239ad62706302 (patch)
treef4e5313129c4470799f1d10e90f6700b5aaefeba
parent25ddaaa73751afe7f8be388526dc97188b977ee4 (diff)
downloadaur-06b2ba3b4bf46a952e8f83592e8239ad62706302.tar.gz
publish v4.0.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD29
2 files changed, 22 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 618e304388c7..7d26eaa31824 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = boostchanger-git
pkgdesc = Control your CPU Turbo Boost with this App
- pkgver = 3.8
- pkgrel = 0
- url = https://gitlab.com/nbebaw/boostchanger
+ pkgver = 4.0
+ pkgrel = 2
+ url = https://github.com/nbebaw/boostchanger
arch = any
license = MIT
makedepends = git
- source = https://gitlab.com/nbebaw/boostchanger/-/archive/v3.8/boostchanger-v3.8.tar.gz
+ makedepends = wget
+ makedepends = unzip
+ source = https://github.com/nbebaw/boostchanger/releases/download/v4.0.2/boostchanger-4.0.2.zip
md5sums = SKIP
pkgname = boostchanger-git
diff --git a/PKGBUILD b/PKGBUILD
index f53834c66ae9..e3a4e7c27e89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,28 +5,31 @@
# Maintainer: nbebaw
pkgname=boostchanger-git
-pkgver=3.8
-pkgrel=0
+pkgver=4.0
+pkgrel=2
pkgdesc="Control your CPU Turbo Boost with this App"
arch=('any')
-url="https://gitlab.com/nbebaw/boostchanger"
+url="https://github.com/nbebaw/boostchanger"
license=('MIT')
-makedepends=('git')
-source=("https://gitlab.com/nbebaw/boostchanger/-/archive/v$pkgver/boostchanger-v$pkgver.tar.gz")
+makedepends=('git' 'wget' 'unzip')
+source=("https://github.com/nbebaw/boostchanger/releases/download/v$pkgver.$pkgrel/boostchanger-$pkgver.$pkgrel.zip")
md5sums=('SKIP')
prepare() {
- pkgverold=3.6
- rm -rf ${pkgdir}/opt/boostchanger-v$pkgverold
- tar -xf boostchanger-v$pkgver.tar.gz
+ pkgverold=4.0.1
+ rm -rf ${pkgdir}/opt/boostchanger-$pkgverold
+ unzip -d boostchanger-$pkgver.$pkgrel boostchanger-$pkgver.$pkgrel.zip
}
package() {
mkdir -p ${pkgdir}/opt
- cd boostchanger-v$pkgver/app
- cp -r boostchanger-v$pkgver ${pkgdir}/opt
- install -Dm755 boostchanger.sh ${pkgdir}/usr/bin/boostchanger
- install -Dm644 boostchanger.desktop ${pkgdir}/usr/share/applications/boostchanger.desktop
- install -Dm644 boostchanger.png ${pkgdir}/usr/share/pixmaps/boostchanger.png
+ cp -r boostchanger-$pkgver.$pkgrel ${pkgdir}/opt
+ wget https://github.com/nbebaw/boostchanger/archive/v$pkgver.$pkgrel.zip
+ unzip v$pkgver.$pkgrel.zip
+ install -Dm755 boostchanger-$pkgver.$pkgrel/build/boostchanger.sh ${pkgdir}/usr/bin/boostchanger
+ install -Dm644 boostchanger-$pkgver.$pkgrel/build/boostchanger.desktop ${pkgdir}/usr/share/applications/boostchanger.desktop
+ install -Dm644 boostchanger-$pkgver.$pkgrel/build/icon.png ${pkgdir}/usr/share/pixmaps/boostchanger.png
+ rm -rf boostchanger-$pkgver.$pkgrel
+ rm v$pkgver.$pkgrel.zip
}