summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZile9952024-01-06 15:08:33 +0100
committerZile9952024-01-06 15:08:33 +0100
commit8d921bfddd91055796f20642fafd3dc9750aa8d6 (patch)
treeb90380e89936a0e1d1628504dbee37c56e0f8862
downloadaur-8d921bfddd91055796f20642fafd3dc9750aa8d6.tar.gz
Initial commit
Signed-off-by: Zile995 <stefan.zivkovic995@gmail.com>
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD57
3 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc8bb54752e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = booster-um-git
+ pkgdesc = Booster UKI Manager - A simple bash script to manage UKI files generated by booster and systemd-ukify
+ pkgver = 1.4.r2.g5163855
+ pkgrel = 1
+ url = https://github.com/Zile995/booster-um
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = booster
+ depends = go-yq
+ depends = systemd
+ depends = systemd-ukify
+ depends = util-linux
+ optdepends = sbctl: Sign the UKI files
+ optdepends = sbsigntools: Sign the UKI files with sbsign
+ optdepends = efibootmgr: Manage EFI entries
+ provides = booster-um
+ conflicts = booster-um
+ backup = etc/booster-um.yaml
+ source = booster-um-git::git+https://github.com/Zile995/booster-um
+ md5sums = SKIP
+
+pkgname = booster-um-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..db1cee14a384
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+# Ignore makepkg files and dirs
+pkg/
+src/
+booster-um-git/
+
+# Ignore pacman packages
+*.pkg.tar.zst
+
+# Do not ignore PKGBUILD files
+!PKGBUILD
+!*.install
+
+# Do not ignore common files
+!*.diff
+!*.patch
+
+# Ignore vscode
+.vscode/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df299df7ee9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Zile995 <stefan.zivkovic995@gmail.com>
+
+pkgname=booster-um-git
+pkgver=1.4.r2.g5163855
+pkgrel=1
+pkgdesc="Booster UKI Manager - A simple bash script to manage UKI files generated by booster and systemd-ukify"
+url="https://github.com/Zile995/booster-um"
+arch=('any')
+license=('GPL3')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+backup=(etc/booster-um.yaml)
+depends=('booster' 'go-yq' 'systemd' 'systemd-ukify' 'util-linux')
+optdepends=("sbctl: Sign the UKI files"
+ "sbsigntools: Sign the UKI files with sbsign"
+ "efibootmgr: Manage EFI entries")
+makedepends=('git')
+source=("${pkgname}::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+
+ # Create config file
+ mkdir "${pkgdir}/etc/"
+ touch "${pkgdir}/etc/booster-um.yaml"
+
+ # Install the booster-um
+ install -Dm0755 booster-um -t "${pkgdir}/usr/bin"
+
+ # Install the helper scripts
+ for script in scripts/*; do
+ install -Dm0755 "$script" -t "${pkgdir}/usr/share/booster-um"
+ done
+
+ # Install the libaplm scripts
+ for libalpm_script in libalpm/scripts/*; do
+ install -Dm0755 "$libalpm_script" -t "${pkgdir}/usr/share/libalpm/scripts"
+ done
+
+ # Install the libalpm hooks
+ for libalpm_hook in libalpm/hooks/*; do
+ install -Dm0644 "$libalpm_hook" -t "${pkgdir}/usr/share/libalpm/hooks"
+ done
+
+ # Install completions
+ install -Dm644 "completions/zsh/_${pkgname%-*}" -t "${pkgdir}/usr/share/zsh/site-functions/"
+ install -Dm644 "completions/bash/${pkgname%-*}" -t "${pkgdir}/usr/share/bash-completion/completions"
+
+ # Install the LICENSE
+ install -Dm0644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}