summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJannick Hemelhof2017-04-08 16:46:49 +0200
committerJannick Hemelhof2017-04-08 16:46:49 +0200
commit0d403c54216a3a2ac1323024e99e37933a6e18e7 (patch)
tree7bedce93ed5ef0d4bea55a1a0256018a7b5dc6f7
parentbb8591ddc37293b1083bc8c6a43746464a32ca5a (diff)
downloadaur-0d403c54216a3a2ac1323024e99e37933a6e18e7.tar.gz
Fix for nearly all warnings
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD43
-rw-r--r--warning-prune-fix.patch72
3 files changed, 97 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06614e5828e8..c4b8d6d0a33f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = boostnote
pkgdesc = Open source note-taking app for programmers
pkgver = 0.8.7
- pkgrel = 3
+ pkgrel = 4
url = https://boostnote.io/
arch = any
license = GPL3
@@ -9,14 +9,15 @@ pkgbase = boostnote
makedepends = grunt-cli
makedepends = git
depends = electron
+ depends = nodejs
source = 0.8.7.tar.gz::https://github.com/BoostIO/Boostnote/archive/v0.8.7.tar.gz
source = boostnote.js
source = boostnote.desktop
- source = npm-prune-fix.patch
+ source = warning-prune-fix.patch
sha512sums = 400bcd5f2a2fa3c858c4e5ab8ce22c8f9669a5c1c0299724937f56534248e0517c8a814b7c2f2243c8492edbb50e96b2a2a2ce787f6566cbfec1741521d5261c
sha512sums = f0abbdcca34d7f74d3dc66ffc2d0995416e7708c715d55fa58c4c2abc31d191ea42f3434e3105292b4817f83ac0ca89f456f5f93007ae80ab2426c8941f615f9
sha512sums = 18bcda13580da8ceeaa86793a77ec00a053b8fd51451dad7e2b1a19553fe1a467ac647b44b789212e783f3f6a80968cc9404e884ef7ff6b1f6588473b3229d40
- sha512sums = c500237c18fc1fcd98f3fd6d1b0bd74764e6f53a87c258b4d68b6d4754ad2281317b89e411aaf5af4d2c9f837f67218cd3663e27fc77da5137b217724f91039c
+ sha512sums = 4b57a26cfa2bfb6e03c8c4c08f2ce2e6707cd95ad8c0593ef890cb3ae5d7d032169b829c4359b9663eb775ddd630fc4f93de515f89659a5877874eb5f23598ea
pkgname = boostnote
diff --git a/PKGBUILD b/PKGBUILD
index 84559f16a4dc..7a33f367ebbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,46 @@
# Maintainer: Jannick Hemelhof <mister {dot} jannick {at} gmail {dot} com>
+# Contributor: Nicola Squartini <tensor5 {at} gmail {dot} com>
# Contributor: NicoHood <aur {at} nicohood {dot} de>
# Contributor: Dick Choi <fluke8259 {at} gmail {dot} com>
# Contributor: Romain Bazile <gromain {dot} baz {at} gmail {dot} com>
pkgname=boostnote
_pkgname=Boostnote
pkgver=0.8.7
-pkgrel=3
+pkgrel=4
pkgdesc="Open source note-taking app for programmers"
arch=('any')
url="https://boostnote.io/"
license=('GPL3')
-depends=('electron')
+depends=('electron' 'nodejs')
makedepends=('npm' 'grunt-cli' 'git')
source=(
"${pkgver}.tar.gz::https://github.com/BoostIO/"${_pkgname}"/archive/v"$pkgver".tar.gz"
"${pkgname}.js"
"${pkgname}.desktop"
- "npm-prune-fix.patch"
+ "warning-prune-fix.patch"
)
sha512sums=(
'400bcd5f2a2fa3c858c4e5ab8ce22c8f9669a5c1c0299724937f56534248e0517c8a814b7c2f2243c8492edbb50e96b2a2a2ce787f6566cbfec1741521d5261c'
'f0abbdcca34d7f74d3dc66ffc2d0995416e7708c715d55fa58c4c2abc31d191ea42f3434e3105292b4817f83ac0ca89f456f5f93007ae80ab2426c8941f615f9'
'18bcda13580da8ceeaa86793a77ec00a053b8fd51451dad7e2b1a19553fe1a467ac647b44b789212e783f3f6a80968cc9404e884ef7ff6b1f6588473b3229d40'
- 'c500237c18fc1fcd98f3fd6d1b0bd74764e6f53a87c258b4d68b6d4754ad2281317b89e411aaf5af4d2c9f837f67218cd3663e27fc77da5137b217724f91039c'
+ '4b57a26cfa2bfb6e03c8c4c08f2ce2e6707cd95ad8c0593ef890cb3ae5d7d032169b829c4359b9663eb775ddd630fc4f93de515f89659a5877874eb5f23598ea'
)
prepare() {
cd "${_pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/npm-prune-fix.patch"
+ patch -Np1 -i "${srcdir}/warning-prune-fix.patch"
}
build() {
cd "${_pkgname}-${pkgver}"
- npm install
+ npm install --no-optional
grunt compile
+ # Kind of silly way of avoiding an npm warning
+ npm uninstall eslint-config-standard
npm prune --production
- cp resources/app.png ../app.png
}
package() {
@@ -51,22 +53,19 @@ package() {
install -Dm755 "${srcdir}/${pkgname}.js" "$pkgdir/usr/bin/${pkgname}"
- install -Dm644 "${srcdir}/app.png" "$pkgdir/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 resources/app.png "$pkgdir/usr/share/pixmaps/${pkgname}.png"
install -Dm644 "${srcdir}/${pkgname}.desktop" "$pkgdir/usr/share/applications/${pkgname}.desktop"
- find "${pkgdir}""${appdir}" \
- -name "package.json" \
- -exec sed -e "s|${srcdir}/${pkgname}-${pkgver}|${appdir}|" \
- -i {} \; \
- -or -name ".*" -prune -exec rm -r '{}' \; \
- -or -name "Gruntfile.js" -exec rm '{}' \; \
- -or -name "Makefile" -exec rm '{}' \; \
- -or -name "bower.json" -exec rm '{}' \; \
- -or -name "cmd.js" -exec rm '{}' \; \
- -or -name "coffee" -prune -exec rm -r '{}' \; \
- -or -name "example" -prune -exec rm -r '{}' \; \
- -or -name "gulpfile.js" -exec rm '{}' \; \
- -or -name "test" -prune -exec rm -r '{}' \; \
- -or -name "tests" -prune -exec rm -r '{}' \;
+ # Remove stuff we do not need
+ find "${pkgdir}"/usr/lib/"${pkgname}"/node_modules \
+ -name "*.a" -exec rm '{}' \; \
+ -or -name "*.bat" -exec rm '{}' \; \
+ -or -name "*.node" -exec chmod a-x '{}' \; \
+ -or -name "benchmark" -prune -exec rm -r '{}' \; \
+ -or -name "doc" -prune -exec rm -r '{}' \; \
+ -or -name "html" -prune -exec rm -r '{}' \; \
+ -or -name "man" -prune -exec rm -r '{}' \; \
+ -or -path "*/less/gradle" -prune -exec rm -r '{}' \; \
+ -or -path "*/task-lists/src" -prune -exec rm -r '{}' \;
}
diff --git a/warning-prune-fix.patch b/warning-prune-fix.patch
new file mode 100644
index 000000000000..c79c1cac8008
--- /dev/null
+++ b/warning-prune-fix.patch
@@ -0,0 +1,72 @@
+diff -ura a/gruntfile.js b/gruntfile.js
+--- a/gruntfile.js 2017-03-20 08:11:24.000000000 +0100
++++ b/gruntfile.js 2017-04-08 15:03:17.256859446 +0200
+@@ -6,6 +6,7 @@
+
+ module.exports = function (grunt) {
+ var authCode
++/*
+ try {
+ authCode = grunt.file.readJSON('secret/auth_code.json')
+ } catch (e) {
+@@ -13,6 +14,7 @@
+ console.warn('secret/auth_code.json is not found. CodeSigning is not available.')
+ }
+ }
++*/
+ const OSX_COMMON_NAME = authCode != null ? authCode.OSX_COMMON_NAME : ''
+ const WIN_CERT_PASSWORD = authCode != null ? authCode.WIN_CERT_PASSWORD : ''
+
+@@ -55,9 +57,6 @@
+
+ grunt.initConfig(initConfig)
+ grunt.loadNpmTasks('grunt-electron-installer')
+- if (!WIN) {
+- grunt.loadNpmTasks('grunt-electron-installer-debian')
+- }
+
+ grunt.registerTask('compile', function () {
+ var done = this.async()
+diff -ura a/package.json b/package.json
+--- a/package.json 2017-03-20 08:11:24.000000000 +0100
++++ b/package.json 2017-04-08 15:33:41.702192334 +0200
+@@ -87,35 +86,29 @@
+ "css-loader": "^0.19.0",
+ "devtron": "^1.1.0",
+ "dom-storage": "^2.0.2",
+- "electron-packager": "^6.0.0",
+- "electron-prebuilt": "^1.2.8",
++ "electron-packager": "^8.6.0",
+ "eslint": "^3.13.1",
+ "eslint-config-standard": "^6.2.1",
+ "eslint-config-standard-jsx": "^3.2.0",
+ "faker": "^3.1.0",
+- "grunt": "^0.4.5",
+- "grunt-electron-installer": "^1.2.0",
++ "grunt": "^1.0.1",
++ "grunt-electron-installer": "^2.1.0",
+ "history": "^1.17.0",
+ "jsdom": "^9.4.2",
+ "merge-stream": "^1.0.0",
+ "nib": "^1.1.0",
+- "react": "^15.3.0",
+ "react-color": "^2.2.2",
+ "react-css-modules": "^3.7.6",
+- "react-dom": "^15.3.0",
+ "react-input-autosize": "^1.1.0",
+ "react-router": "^2.4.0",
+ "react-router-redux": "^4.0.4",
+ "standard": "^8.4.0",
+ "style-loader": "^0.12.4",
+- "stylus": "^0.52.4",
++ "stylus": "^0.54.5",
+ "stylus-loader": "^2.3.1",
+ "webpack": "^1.12.2",
+ "webpack-dev-server": "^1.12.0"
+ },
+- "optionalDependencies": {
+- "grunt-electron-installer-debian": "^0.2.0"
+- },
+ "optional": false,
+ "ava": {
+ "files": [