summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJannick Hemelhof2017-04-22 16:57:25 +0200
committerJannick Hemelhof2017-04-22 16:57:25 +0200
commit1f0ea3e24769064b03c14a50b7578585c3348d0c (patch)
tree8d41831e4107a5ff5aed4f6cbf1e642da9fe1e7f
parent0d403c54216a3a2ac1323024e99e37933a6e18e7 (diff)
downloadaur-1f0ea3e24769064b03c14a50b7578585c3348d0c.tar.gz
Updated for 0.8.8
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
-rw-r--r--warning-fix.patch66
3 files changed, 78 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4b8d6d0a33f..69917bd8aea6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = boostnote
pkgdesc = Open source note-taking app for programmers
- pkgver = 0.8.7
- pkgrel = 4
+ pkgver = 0.8.8
+ pkgrel = 1
url = https://boostnote.io/
arch = any
license = GPL3
@@ -10,14 +10,14 @@ pkgbase = boostnote
makedepends = git
depends = electron
depends = nodejs
- source = 0.8.7.tar.gz::https://github.com/BoostIO/Boostnote/archive/v0.8.7.tar.gz
+ source = 0.8.8.tar.gz::https://github.com/BoostIO/Boostnote/archive/v0.8.8.tar.gz
source = boostnote.js
source = boostnote.desktop
- source = warning-prune-fix.patch
- sha512sums = 400bcd5f2a2fa3c858c4e5ab8ce22c8f9669a5c1c0299724937f56534248e0517c8a814b7c2f2243c8492edbb50e96b2a2a2ce787f6566cbfec1741521d5261c
+ source = warning-fix.patch
+ sha512sums = 26de3511a7fa4f98c482677575a635b3b5cb4b33c5db92c80007f9a77c674b9d7eb6d7a3e721936e4f350a9448af93b27b443befd26169fc4605f253f2088596
sha512sums = f0abbdcca34d7f74d3dc66ffc2d0995416e7708c715d55fa58c4c2abc31d191ea42f3434e3105292b4817f83ac0ca89f456f5f93007ae80ab2426c8941f615f9
sha512sums = 18bcda13580da8ceeaa86793a77ec00a053b8fd51451dad7e2b1a19553fe1a467ac647b44b789212e783f3f6a80968cc9404e884ef7ff6b1f6588473b3229d40
- sha512sums = 4b57a26cfa2bfb6e03c8c4c08f2ce2e6707cd95ad8c0593ef890cb3ae5d7d032169b829c4359b9663eb775ddd630fc4f93de515f89659a5877874eb5f23598ea
+ sha512sums = 64fb4c4823744322b5777736fc1792fb377e433608b5456cb0e0b7053507d104a1bbe3fdc6fe193b41dfddadc1943e8220a27e26ec6d4166704f3e61e2572437
pkgname = boostnote
diff --git a/PKGBUILD b/PKGBUILD
index 7a33f367ebbd..1004763ccec5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Romain Bazile <gromain {dot} baz {at} gmail {dot} com>
pkgname=boostnote
_pkgname=Boostnote
-pkgver=0.8.7
-pkgrel=4
+pkgver=0.8.8
+pkgrel=1
pkgdesc="Open source note-taking app for programmers"
arch=('any')
url="https://boostnote.io/"
@@ -18,20 +18,20 @@ source=(
"${pkgver}.tar.gz::https://github.com/BoostIO/"${_pkgname}"/archive/v"$pkgver".tar.gz"
"${pkgname}.js"
"${pkgname}.desktop"
- "warning-prune-fix.patch"
+ "warning-fix.patch"
)
sha512sums=(
- '400bcd5f2a2fa3c858c4e5ab8ce22c8f9669a5c1c0299724937f56534248e0517c8a814b7c2f2243c8492edbb50e96b2a2a2ce787f6566cbfec1741521d5261c'
+ '26de3511a7fa4f98c482677575a635b3b5cb4b33c5db92c80007f9a77c674b9d7eb6d7a3e721936e4f350a9448af93b27b443befd26169fc4605f253f2088596'
'f0abbdcca34d7f74d3dc66ffc2d0995416e7708c715d55fa58c4c2abc31d191ea42f3434e3105292b4817f83ac0ca89f456f5f93007ae80ab2426c8941f615f9'
'18bcda13580da8ceeaa86793a77ec00a053b8fd51451dad7e2b1a19553fe1a467ac647b44b789212e783f3f6a80968cc9404e884ef7ff6b1f6588473b3229d40'
- '4b57a26cfa2bfb6e03c8c4c08f2ce2e6707cd95ad8c0593ef890cb3ae5d7d032169b829c4359b9663eb775ddd630fc4f93de515f89659a5877874eb5f23598ea'
+ '64fb4c4823744322b5777736fc1792fb377e433608b5456cb0e0b7053507d104a1bbe3fdc6fe193b41dfddadc1943e8220a27e26ec6d4166704f3e61e2572437'
)
prepare() {
cd "${_pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/warning-prune-fix.patch"
+ patch -Np1 -i "${srcdir}/warning-fix.patch"
}
build() {
@@ -68,4 +68,3 @@ package() {
-or -path "*/less/gradle" -prune -exec rm -r '{}' \; \
-or -path "*/task-lists/src" -prune -exec rm -r '{}' \;
}
-
diff --git a/warning-fix.patch b/warning-fix.patch
new file mode 100644
index 000000000000..b1fdad34acbe
--- /dev/null
+++ b/warning-fix.patch
@@ -0,0 +1,66 @@
+diff -ura a/gruntfile.js b/gruntfile.js
+--- a/gruntfile.js 2017-04-22 11:30:05.000000000 +0200
++++ b/gruntfile.js 2017-04-22 16:44:11.418409532 +0200
+@@ -6,6 +6,7 @@
+
+ module.exports = function (grunt) {
+ var authCode
++ /*
+ try {
+ authCode = grunt.file.readJSON('secret/auth_code.json')
+ } catch (e) {
+@@ -13,6 +14,7 @@
+ console.warn('secret/auth_code.json is not found. CodeSigning is not available.')
+ }
+ }
++ */
+ const OSX_COMMON_NAME = authCode != null ? authCode.OSX_COMMON_NAME : ''
+ const WIN_CERT_PASSWORD = authCode != null ? authCode.WIN_CERT_PASSWORD : ''
+
+@@ -55,9 +57,6 @@
+
+ grunt.initConfig(initConfig)
+ grunt.loadNpmTasks('grunt-electron-installer')
+- if (!WIN) {
+- grunt.loadNpmTasks('grunt-electron-installer-debian')
+- }
+
+ grunt.registerTask('compile', function () {
+ var done = this.async()
+diff -ura a/package.json b/package.json
+--- a/package.json 2017-04-22 11:30:05.000000000 +0200
++++ b/package.json 2017-04-22 16:45:28.247081093 +0200
+@@ -90,14 +90,13 @@
+ "css-loader": "^0.19.0",
+ "devtron": "^1.1.0",
+ "dom-storage": "^2.0.2",
+- "electron-packager": "^6.0.0",
+- "electron-prebuilt": "^1.2.8",
++ "electron-packager": "^8.6.0",
+ "eslint": "^3.13.1",
+ "eslint-config-standard": "^6.2.1",
+ "eslint-config-standard-jsx": "^3.2.0",
+ "faker": "^3.1.0",
+- "grunt": "^0.4.5",
+- "grunt-electron-installer": "^1.2.0",
++ "grunt": "^1.0.1",
++ "grunt-electron-installer": "^2.1.0",
+ "history": "^1.17.0",
+ "jsdom": "^9.4.2",
+ "merge-stream": "^1.0.0",
+@@ -109,14 +108,11 @@
+ "react-router-redux": "^4.0.4",
+ "standard": "^8.4.0",
+ "style-loader": "^0.12.4",
+- "stylus": "^0.52.4",
++ "stylus": "^0.54.5",
+ "stylus-loader": "^2.3.1",
+ "webpack": "^1.12.2",
+ "webpack-dev-server": "^1.12.0"
+ },
+- "optionalDependencies": {
+- "grunt-electron-installer-debian": "^0.2.0"
+- },
+ "optional": false,
+ "ava": {
+ "files": [