summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFraV19822024-03-24 20:13:24 +0100
committerFraV19822024-03-24 20:13:24 +0100
commita995b2c71947bcfa63938d7b3b17460c7d1a97df (patch)
treeb11670b5130afd1bc6e5d0c1eebba587240c130b
downloadaur-a995b2c71947bcfa63938d7b3b17460c7d1a97df.tar.gz
1st publication
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2dac244a8e31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = boot-repair
+ pkgdesc = A little software for MBR and Boot Record recovery.
+ pkgver = 4ppa200
+ pkgrel = 1
+ url = https://sourceforge.net/p/boot-repair/home/Home/
+ arch = x86_64
+ arch = aarch64
+ arch = armv6h
+ arch = armv7h
+ arch = i686
+ license = GPL
+ depends = boot-sav
+ options = !emptydirs
+ options = !strip
+ source = https://ftp5.gwdg.de/pub/linux/debian/mint/packages/pool/import/b/boot-repair/boot-repair_4ppa200_all.deb
+ md5sums = SKIP
+ sha256sums = SKIP
+ sha512sums = SKIP
+
+pkgname = boot-repair
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11f5928a6654
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: FraV1982 <consulenza dot vangi at outlook dot com>
+
+pkgname=boot-repair
+pkgver=4ppa200
+pkgrel=1
+pkgdesc="A little software for MBR and Boot Record recovery."
+arch=(x86_64 aarch64 armv6h armv7h i686)
+url="https://sourceforge.net/p/boot-repair/home/Home/"
+license=('GPL')
+depends=('boot-sav')
+options=("!emptydirs" "!strip")
+
+_debname=boot-repair_4ppa200_all.deb
+
+source=(https://ftp5.gwdg.de/pub/linux/debian/mint/packages/pool/import/b/boot-repair/boot-repair_4ppa200_all.deb)
+md5sums=('SKIP')
+sha256sums=('SKIP')
+sha512sums=('SKIP')
+
+prepare() {
+ cd "$srcdir"
+ msg2 "Decompressing Debian package boot-repair..."
+ ar xv "${_debname}" > /dev/null
+ tar -xf data.tar.xz > /dev/null
+
+ find ./etc -type d -exec chmod 755 '{}' \;
+ find ./usr -type d -exec chmod 755 '{}' \;
+}
+
+package() {
+ cd "$srcdir"
+ cp -dpr --no-preserve=ownership {etc,usr} "$pkgdir"
+}