summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Price2015-08-03 19:40:16 +0100
committerWill Price2015-08-03 19:40:16 +0100
commit8459d7610aa4d0108b50a771e8e695238a83016a (patch)
treee76b138e5c1ddf425c569bce2b35ead031fcbdfc
downloadaur-8459d7610aa4d0108b50a771e8e695238a83016a.tar.gz
Initial import
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD47
3 files changed, 82 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..45acc2adcbcd
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = boot-vhdl-git
+ pkgdesc = A VHDL simulator and synthesizer
+ pkgver = 4.5
+ pkgrel = 1
+ url = https://code.google.com/p/boot-vhdl/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ depends = ghdl
+ depends = pywebkitgtk
+ depends = python2-mechanize
+ depends = python2-pygments
+ source = boot-vhdl::git+https://code.google.com/p/boot-vhdl/
+
+pkgname = boot-vhdl-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a0460b3e13c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = boot-vhdl-git
+ pkgdesc = A VHDL simulator and synthesizer
+ pkgver = 4.5
+ pkgrel = 1
+ url = https://code.google.com/p/boot-vhdl/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ depends = ghdl
+ depends = pywebkitgtk
+ depends = python2-mechanize
+ depends = python2-pygments
+ source = boot-vhdl::git+https://code.google.com/p/boot-vhdl/
+ md5sums = SKIP
+
+pkgname = boot-vhdl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39437b91af94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Will Price <will.price94+aur@gmail.com>
+
+pkgname=boot-vhdl-git
+pkgver=4.5
+pkgrel=1
+pkgdesc="A VHDL simulator and synthesizer"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="https://code.google.com/p/boot-vhdl/"
+depends=('python2' 'ghdl' 'pywebkitgtk' 'python2-mechanize'
+'python2-pygments')
+source=('boot-vhdl::git+https://code.google.com/p/boot-vhdl/')
+md5sums=('SKIP')
+
+prepare() {
+ _fix_python_invocations
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/{bin,share/{applications,pixmaps,boot-vhdl}}
+ cp -r "$srcdir"/boot-vhdl/boot_scr/*.py \
+ "$pkgdir/usr/share/boot-vhdl/"
+ cp -r "$srcdir/boot-vhdl/boot_scr/old" \
+ "$pkgdir/usr/share/boot-vhdl/"
+ cp -r "$srcdir/boot-vhdl/LICENSE" \
+ "$pkgdir/usr/share/boot-vhdl/LICENSE"
+
+ for _suffix in png svg; do
+ cp "$srcdir/boot-vhdl/boot_scr/boot-icon.$_suffix" \
+ "$pkgdir/usr/share/pixmaps"
+ done
+
+ cp "$srcdir/boot-vhdl/boot_scr/boot.desktop" \
+ "$pkgdir/usr/share/applications"
+ cat << EOF > "$pkgdir/usr/bin/boot"
+#!/bin/sh
+python2 /usr/share/boot-vhdl/boot.py
+EOF
+ chmod 755 "$pkgdir/usr/bin/boot"
+}
+
+_fix_python_invocations() {
+ # | replaces / as it's easier to identify
+ sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
+ -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ $(find $srcdir -name '*.py')
+}