summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquininer2018-05-27 11:02:45 +0800
committerquininer2018-05-27 11:02:45 +0800
commit4e6192217896822b325c9558d205ec93e5cbc4e3 (patch)
tree33cfe859efc0337c0555574910a43231c3011205
downloadaur-4e6192217896822b325c9558d205ec93e5cbc4e3.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1678607a234
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bootimage-git
+ pkgdesc = Tool to create a bootable OS image from a kernel binary.
+ pkgver = 0.3.0.66
+ pkgrel = 1
+ url = https://github.com/rust-osdev/bootimage
+ arch = i686
+ arch = x86_64
+ license = NULL
+ makedepends = rust
+ makedepends = cargo
+ provides = bootimage
+ conflicts = bootimage
+ source = bootimage::git+https://github.com/rust-osdev/bootimage
+ sha256sums = SKIP
+
+pkgname = bootimage-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c991e87321b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=bootimage-git
+_pkgname=bootimage
+pkgdesc="Tool to create a bootable OS image from a kernel binary."
+pkgrel=1
+pkgver=0.3.0.66
+arch=('i686' 'x86_64')
+conflicts=("bootimage")
+provides=("bootimage")
+url="https://github.com/rust-osdev/bootimage"
+license=('NULL')
+depends=()
+makedepends=('rust' 'cargo')
+optdepends=()
+source=("$_pkgname::git+https://github.com/rust-osdev/bootimage")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2|cut -d\- -f1).$(git rev-list --count HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ env CARGO_INCREMENTAL=0 cargo build --release
+}
+
+package() {
+ cd $_pkgname
+ install -D -m755 "$srcdir/$_pkgname/target/release/bootimage" "$pkgdir/usr/bin/bootimage"
+}