summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorANDRoid78902021-02-07 15:41:51 +0400
committerANDRoid78902021-02-07 15:41:51 +0400
commit8a0f1345f1a94850f31f0ec3e953e197d0ceaa65 (patch)
tree8191d2a8d8e5c323ca6dc31d3ca2211f60a5f3fd
downloadaur-8a0f1345f1a94850f31f0ec3e953e197d0ceaa65.tar.gz
1.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5601c62f0511
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bootsplash-manager-bin
+ pkgdesc = Simple cli bootsplash manager
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/ANDRoid7890/bootsplash-manager
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ depends = qt5-base
+ depends = bootsplash-systemd
+ source = https://github.com/ANDRoid7890/bootsplash-manager/releases/download/1.0/bootsplash-manager.tar.gz
+ md5sums = 7f94cbeeaf2f1a11aa0c55d3c4a3bbdf
+
+pkgname = bootsplash-manager-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..904d5a520238
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: ANDRoid7890 <andrey.android7890@gmail.com>
+
+pkgname=bootsplash-manager-bin
+pkgver=1.0
+pkgrel=1
+pkgdesc="Simple cli bootsplash manager"
+url="https://github.com/ANDRoid7890/bootsplash-manager"
+arch=(x86_64)
+license=(GPL2)
+depends=('qt5-base'
+ 'bootsplash-systemd')
+makedepends=(cmake)
+
+source=("https://github.com/ANDRoid7890/bootsplash-manager/releases/download/1.0/bootsplash-manager.tar.gz")
+
+md5sums=('7f94cbeeaf2f1a11aa0c55d3c4a3bbdf')
+
+package() {
+ install -Dm755 bootsplash-manager "$pkgdir/usr/bin/bootsplash-manager"
+ install -Dm644 org.manjaro.bootsplash-manager.policy "$pkgdir/usr/share/polkit-1/actions/org.manjaro.bootsplash-manager.policy"
+}