summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYury Kurlykov2018-10-31 19:17:03 +1000
committerYury Kurlykov2018-10-31 19:19:27 +1000
commit1910e62d991c363fd29392343b0621390a816d19 (patch)
treedc1c975c11e962e496d46f594a2d5033db62c0d6
downloadaur-1910e62d991c363fd29392343b0621390a816d19.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
-rw-r--r--bootsplash-bgrt.initcpio_install11
-rwxr-xr-xbootsplash-bgrt.sh78
-rwxr-xr-xbootsplash-packerbin0 -> 22160 bytes
-rw-r--r--spinner.gifbin0 -> 8374 bytes
6 files changed, 153 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca82009236c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = bootsplash-theme-bgrt
+ pkgdesc = BGRT bootsplash theme
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://lists.freedesktop.org/archives/dri-devel/2017-December/160242.html
+ arch = x86_64
+ license = GPL
+ makedepends = imagemagick
+ optdepends = bootsplash-systemd: for bootsplash functionality
+ options = !libtool
+ options = !emptydirs
+ source = bootsplash-packer
+ source = bootsplash-bgrt.sh
+ source = bootsplash-bgrt.initcpio_install
+ source = spinner.gif
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = bootsplash-theme-bgrt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..049147d3c93b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Yury Kurlykov <kurlykster@mail.ru>
+pkgname='bootsplash-theme-bgrt'
+pkgver=0.1
+pkgrel=1
+pkgdesc="BGRT bootsplash theme"
+url="https://lists.freedesktop.org/archives/dri-devel/2017-December/160242.html"
+arch=('x86_64')
+license=('GPL')
+
+optdepends=('bootsplash-systemd: for bootsplash functionality')
+makedepends=('imagemagick')
+options=('!libtool' '!emptydirs')
+
+source=('bootsplash-packer'
+ 'bootsplash-bgrt.sh'
+ 'bootsplash-bgrt.initcpio_install'
+ 'spinner.gif')
+
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ echo "Checking for BGRT..."
+ if [ ! -f "/sys/firmware/acpi/bgrt/version" ]
+ then
+ echo "BGRT not found, aborting..."
+ exit 1
+ fi
+}
+
+build() {
+ cd "$srcdir"
+ sh ./bootsplash-bgrt.sh
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm644 "$srcdir/bootsplash-bgrt" "$pkgdir/usr/lib/firmware/bootsplash-themes/bgrt/bootsplash"
+ install -Dm644 "$srcdir/bootsplash-bgrt.initcpio_install" "$pkgdir/usr/lib/initcpio/install/bootsplash-bgrt"
+}
diff --git a/bootsplash-bgrt.initcpio_install b/bootsplash-bgrt.initcpio_install
new file mode 100644
index 000000000000..4c2192839030
--- /dev/null
+++ b/bootsplash-bgrt.initcpio_install
@@ -0,0 +1,11 @@
+build() {
+ # add bootsplash
+ add_binary /usr/lib/firmware/bootsplash-themes/bgrt/bootsplash /usr/lib/firmware/bootsplash-themes/bgrt/bootsplash
+}
+
+help() {
+ echo "This hook includes bootsplash image in the initramfs image."
+}
+
+# vim: set ft=sh:
+#EOF
diff --git a/bootsplash-bgrt.sh b/bootsplash-bgrt.sh
new file mode 100755
index 000000000000..5349ae7771c1
--- /dev/null
+++ b/bootsplash-bgrt.sh
@@ -0,0 +1,78 @@
+#!/bin/bash
+#
+# A simple script to show how to create a bootsplash.
+# Do with it whatever you wish.
+#
+# This needs ImageMagick for the 'convert' and 'identify' tools.
+#
+
+echo "Dumping BGRT logo..."
+cat /sys/firmware/acpi/bgrt/image > logo.bmp
+if [ $? -ne 0 ]
+then
+ echo "Dumping failed, aborting..." >&2
+ exit 1
+fi
+
+LOGO=logo.bmp
+LOGO_WIDTH=$(identify $LOGO | cut -d " " -f 3 | cut -d x -f 1)
+LOGO_HEIGHT=$(identify $LOGO | cut -d " " -f 3 | cut -d x -f 2)
+
+THROBBER=spinner.gif
+THROBBER_WIDTH=$(identify $THROBBER | head -1 | cut -d " " -f 3 | \
+ cut -d x -f 1)
+THROBBER_HEIGHT=$(identify $THROBBER | head -1 | cut -d " " -f 3 | \
+ cut -d x -f 2)
+
+convert -alpha remove \
+ -background "#000000" \
+ $LOGO \
+ logo.rgb
+
+convert -alpha remove \
+ -background "#000000" \
+ $THROBBER \
+ throbber%02d.rgb
+
+# Let's put Tux in the center of an orange background.
+./bootsplash-packer \
+ --bg_red 0x00 \
+ --bg_green 0x00 \
+ --bg_blue 0x00 \
+ --frame_ms 30 \
+ --picture \
+ --pic_width $LOGO_WIDTH \
+ --pic_height $LOGO_HEIGHT \
+ --pic_position 0 \
+ --blob logo.rgb \
+ --picture \
+ --pic_width $THROBBER_WIDTH \
+ --pic_height $THROBBER_HEIGHT \
+ --pic_position 0x05 \
+ --pic_position_offset 200 \
+ --pic_anim_type 1 \
+ --pic_anim_loop 0 \
+ --blob throbber00.rgb \
+ --blob throbber01.rgb \
+ --blob throbber02.rgb \
+ --blob throbber03.rgb \
+ --blob throbber04.rgb \
+ --blob throbber05.rgb \
+ --blob throbber06.rgb \
+ --blob throbber07.rgb \
+ --blob throbber08.rgb \
+ --blob throbber09.rgb \
+ --blob throbber10.rgb \
+ --blob throbber11.rgb \
+ --blob throbber12.rgb \
+ --blob throbber13.rgb \
+ --blob throbber14.rgb \
+ --blob throbber15.rgb \
+ --blob throbber16.rgb \
+ --blob throbber17.rgb \
+ --blob throbber18.rgb \
+ --blob throbber19.rgb \
+ bootsplash-bgrt
+
+rm *.rgb
+rm logo.bmp
diff --git a/bootsplash-packer b/bootsplash-packer
new file mode 100755
index 000000000000..32dc58496c8e
--- /dev/null
+++ b/bootsplash-packer
Binary files differ
diff --git a/spinner.gif b/spinner.gif
new file mode 100644
index 000000000000..535d155d5cf2
--- /dev/null
+++ b/spinner.gif
Binary files differ