summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Alekseev2020-09-14 21:01:08 +0400
committerAndrey Alekseev2020-09-14 21:01:08 +0400
commit0a66c352c88192c0ba330d8e0067b900a46fa9b0 (patch)
tree34ea4ed4eb1a7cb4923f95993a2ee044e927c9dc
downloadaur-0a66c352c88192c0ba330d8e0067b900a46fa9b0.tar.gz
initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cc48b94933b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bootsplash-theme-manjaro-space-green-git
+ pkgdesc = Beautiful Manjaro Bootsplash with space animation
+ pkgver = 1.0.r18.g9ec6b38
+ pkgrel = 1
+ url = https://github.com/ANDRoid7890/bootsplash-theme-manjaro-space-green
+ arch = x86_64
+ license = GPL
+ makedepends = imagemagick
+ optdepends = bootsplash-systemd: for bootsplash functionality
+ source = git+https://github.com/ANDRoid7890/bootsplash-theme-manjaro-space-green.git
+ sha256sums = SKIP
+
+pkgname = bootsplash-theme-manjaro-space-green-git
+ pkgdesc = Beautiful Manjaro Bootsplash with space animation
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7836e517f445
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Andrey Alekseev <andrey.android7890@gmail.com>
+
+pkgname=('bootsplash-theme-manjaro-space-green-git')
+pkgver=1.0.r18.g9ec6b38
+pkgrel=1
+arch=('x86_64')
+pkgdesc="Beautiful Manjaro Bootsplash with space animation"
+url="https://github.com/ANDRoid7890/bootsplash-theme-manjaro-space-green"
+license=('GPL')
+depends=()
+optdepends=('bootsplash-systemd: for bootsplash functionality')
+makedepends=('imagemagick')
+source=('git+https://github.com/ANDRoid7890/bootsplash-theme-manjaro-space-green.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "bootsplash-theme-manjaro-space-green"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir"/"bootsplash-theme-manjaro-space-green"
+ sh ./bootsplash-manjaro-space.sh
+}
+
+package() {
+ pkgdesc="Beautiful Manjaro Bootsplash with space animation"
+ cd "$srcdir"
+
+ install -Dm644 "$srcdir/bootsplash-theme-manjaro-space-green/bootsplash-manjaro-space-green" "$pkgdir/usr/lib/firmware/bootsplash-themes/manjaro-space-green/bootsplash"
+ install -Dm644 "$srcdir/bootsplash-theme-manjaro-space-green/bootsplash-manjaro-space-green.initcpio_install" "$pkgdir/usr/lib/initcpio/install/bootsplash-manjaro-space-green"
+}