summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorgenstern2020-05-13 12:04:40 +1200
committerMorgenstern2020-05-13 12:04:40 +1200
commit98f5d24cbffe500f84ae77cc26acff60efd64f4a (patch)
tree47c6f0017422ae21838313e16fc7f7c0a3ab971d
parenta6204afe7b58b1c69276b97566f1d0401d27fd25 (diff)
downloadaur-98f5d24cbffe500f84ae77cc26acff60efd64f4a.tar.gz
Update to v4.5.0
-rw-r--r--.SRCINFO10
-rw-r--r--LICENSE4
-rw-r--r--PKGBUILD23
-rw-r--r--bootstrap.install2
4 files changed, 23 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de422ae9e268..616fe7caa0d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = bootstrap
pkgdesc = Open source toolkit for developing with HTML, CSS, and JS
- pkgver = 4.4.1
+ pkgver = 4.5.0
pkgrel = 1
url = https://getbootstrap.com/
install = bootstrap.install
arch = any
license = MIT
- depends = jquery
- source = https://github.com/twbs/bootstrap/releases/download/v4.4.1/bootstrap-4.4.1-dist.zip
+ optdepends = jquery>=3.5.1: for JavaScript plugin support
+ source = https://github.com/twbs/bootstrap/releases/download/v4.5.0/bootstrap-4.5.0-dist.zip
source = LICENSE
- sha256sums = bffa7c741abd4a8558c0946138729f7dcb643491547a0b135fdb77e148b9bfbd
- sha256sums = eaf003ef9d4321de625381657eaa69e0093fa6ab00c0201e3fd4847dd9878461
+ sha256sums = ab96acb6a7a667f3c90692c45f2bb0584976b1b87af5a6142e59392c4238df72
+ sha256sums = 9b2ce2d9793f14f0fb1a77ce64961acc1157fb25858156c47139491107970acb
pkgname = bootstrap
diff --git a/LICENSE b/LICENSE
index 7d1e2311f44f..173a9ebbbd7a 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,7 +1,7 @@
The MIT License (MIT)
-Copyright (c) 2011-2019 Twitter, Inc.
-Copyright (c) 2011-2019 The Bootstrap Authors
+Copyright (c) 2011-2020 Twitter, Inc.
+Copyright (c) 2011-2020 The Bootstrap Authors
Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
diff --git a/PKGBUILD b/PKGBUILD
index 003c62cdd178..bd3a6cfe28e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,27 @@
# Contributor: Mohammadreza Abdollahzadeh <morealaz [at] gmail [dot] com>
pkgname=bootstrap
-pkgver=4.4.1
+pkgver=4.5.0
pkgrel=1
-pkgdesc='Open source toolkit for developing with HTML, CSS, and JS'
+pkgdesc="Open source toolkit for developing with HTML, CSS, and JS"
arch=('any')
-url='https://getbootstrap.com/'
+url="https://getbootstrap.com/"
license=('MIT')
-depends=('jquery')
+optdepends=('jquery>=3.5.1: for JavaScript plugin support')
install=bootstrap.install
source=("https://github.com/twbs/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}-dist.zip"
"LICENSE")
-sha256sums=('bffa7c741abd4a8558c0946138729f7dcb643491547a0b135fdb77e148b9bfbd'
- 'eaf003ef9d4321de625381657eaa69e0093fa6ab00c0201e3fd4847dd9878461')
+sha256sums=('ab96acb6a7a667f3c90692c45f2bb0584976b1b87af5a6142e59392c4238df72'
+ '9b2ce2d9793f14f0fb1a77ce64961acc1157fb25858156c47139491107970acb')
package() {
cd ${pkgname}-${pkgver}-dist
- install -d ${pkgdir}/usr/share/javascript/${pkgname}
- cp -a ./{css,js} ${pkgdir}/usr/share/javascript/${pkgname}/
- install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -d ${pkgdir}/usr/share/javascript/${pkgname}/{css,js}
+ for _jsfile in ./js/*; do
+ install -m0644 "${_jsfile}" "${pkgdir}/usr/share/javascript/${pkgname}/js/"
+ done
+ for _cssfile in ./css/*; do
+ install -m0644 "${_cssfile}" "${pkgdir}/usr/share/javascript/${pkgname}/css/"
+ done
+ install -Dm0644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/bootstrap.install b/bootstrap.install
index 17537d59e1ab..fa3df3a6f1e4 100644
--- a/bootstrap.install
+++ b/bootstrap.install
@@ -1,3 +1,5 @@
post_install() {
+ echo
echo "See https://getbootstrap.com/docs for getting started with Bootstrap"
+ echo
}