summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-11-15 17:21:56 +0800
committerChocobo12017-11-15 18:30:06 +0800
commit800e0aab0ee2cef8ea13c0390e7f62aa75a6a2a8 (patch)
tree153887cbd59c7fbf2e25ca15dbbba8e525de99f5
downloadaur-800e0aab0ee2cef8ea13c0390e7f62aa75a6a2a8.tar.gz
newpkg: bootstrap-dht-git r122.679c661-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e4f06fba766
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bootstrap-dht-git
+ pkgdesc = Bittorrent DHT bootstrap server
+ pkgver = r122.679c661
+ pkgrel = 1
+ url = https://github.com/bittorrent/bootstrap-dht
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = boost-build
+ depends = glibc
+ depends = boost-libs
+ provides = bootstrap-dht
+ conflicts = bootstrap-dht
+ source = git+https://github.com/bittorrent/bootstrap-dht.git
+ sha256sums = SKIP
+
+pkgname = bootstrap-dht-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cea45f8921f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=bootstrap-dht-git
+pkgver=r122.679c661
+pkgrel=1
+pkgdesc="Bittorrent DHT bootstrap server"
+arch=('i686' 'x86_64')
+url="https://github.com/bittorrent/bootstrap-dht"
+license=('MIT')
+depends=('glibc' 'boost-libs')
+makedepends=('git' 'boost-build')
+provides=('bootstrap-dht')
+conflicts=('bootstrap-dht')
+source=("git+https://github.com/bittorrent/bootstrap-dht.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "bootstrap-dht"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "bootstrap-dht"
+
+ b2 "$MAKEFLAGS" release
+}
+
+check() {
+ cd "bootstrap-dht/tests"
+
+ b2 "$MAKEFLAGS" release
+}
+
+package() {
+ cd "bootstrap-dht"
+
+ install -d "$pkgdir/usr/bin/"
+ install -m755 "dht-bootstrap" "$pkgdir/usr/bin/"
+
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/bootstrap-dht/LICENSE"
+}