summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlfin Bakhtiar Ilhami2019-04-14 21:12:17 +0700
committerAlfin Bakhtiar Ilhami2019-04-14 21:12:17 +0700
commit166d3a9736c4a3e38a7756872652f8266297e110 (patch)
treec072955324f28f8f6238c0499b2311661a399c6c
parentb4a08484fd40e0962aa2905e63466ed6b54b5589 (diff)
downloadaur-166d3a9736c4a3e38a7756872652f8266297e110.tar.gz
v4.4.4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD57
-rw-r--r--bootstrap-studio.install26
3 files changed, 44 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6379ee6399f4..2f27f903f139 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = bootstrap-studio
- pkgdesc = Bootstrap Studio is a an app for creating beautiful websites.
- pkgver = 4.1.6
+ pkgdesc = A powerful desktop app for creating responsive websites using the Bootstrap framework.
+ pkgver = 4.4.4
pkgrel = 1
url = https://bootstrapstudio.io/
- install = bootstrap-studio.install
arch = x86_64
- provides = bootstrapstudio
- source = https://bootstrapstudio.io/releases/desktop/4/Bootstrap%20Studio%204%20(64bit).deb
- sha1sums = a76b8f3bebcbdb5abf75e7709f43faf0a6f8f728
+ source = bootstrap-studio-4.4.4.deb::https://bootstrapstudio.io/releases/desktop/4/Bootstrap%20Studio%204%20(64bit).deb
+ sha512sums = ddcfcf6e19de5e1a02931829f6f25982c9cabc6e3995cf133f2fbceaef9736b8ce88af234029ea46a59fa46e886887f2489347778ae71d475edee3c1704a475d
pkgname = bootstrap-studio
diff --git a/PKGBUILD b/PKGBUILD
index 054aeac41c61..73aceb8c0079 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,50 @@
-# Maintainer: Jan-Tarek Butt <tarek@ring0.de>
+# Maintainer: Alfin Bakhtiar Ilhami <alfin at nuclea dot id>
+# Maintainer: Jan-Tarek Butt <tarek at ring0 dot de>
+
pkgbase=bootstrap-studio
pkgname=bootstrap-studio
-pkgver=4.1.6
+pkgver=4.4.4
pkgrel=1
-pkgdesc="Bootstrap Studio is a an app for creating beautiful websites."
-provides=('bootstrapstudio')
-url="https://bootstrapstudio.io/"
+pkgdesc='A powerful desktop app for creating responsive websites using the Bootstrap framework.'
+url='https://bootstrapstudio.io/'
arch=('x86_64')
-source+=("https://bootstrapstudio.io/releases/desktop/4/Bootstrap%20Studio%204%20(64bit).deb")
-sha1sums+=('a76b8f3bebcbdb5abf75e7709f43faf0a6f8f728')
+source=($pkgname-$pkgver.deb::'https://bootstrapstudio.io/releases/desktop/4/Bootstrap%20Studio%204%20(64bit).deb')
+sha512sums=('ddcfcf6e19de5e1a02931829f6f25982c9cabc6e3995cf133f2fbceaef9736b8ce88af234029ea46a59fa46e886887f2489347778ae71d475edee3c1704a475d')
-install=bootstrap-studio.install
-build()
-{
- cd "${srcdir}"
+prepare() {
+ # Extract files
+ tar --xz -xf "$srcdir"/data.tar.xz
- # unpack
- tar --xz -xf data.tar.xz
+ # Fix desktop entry
+ sed -i "s|Exec=.*|Exec=/usr/bin/$pkgname %F|" \
+ "$srcdir"/usr/share/applications/bootstrapstudio.desktop
+
+ sed -i "s|Path=.*|Path=/usr/bin/|" \
+ "$srcdir"/usr/share/applications/bootstrapstudio.desktop
}
-package()
-{
- cp -r "${srcdir}"/opt "${pkgdir}"/opt
- cp -r "${srcdir}"/usr "${pkgdir}"/usr
+package() {
+ # Create directory
+ install -d "$pkgdir"/usr/{lib,bin}
+
+ # Install license
+ install -Dm644 "$srcdir"/usr/share/doc/bootstrapstudio/copyright \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 "$srcdir"/opt/bootstrapstudio/LICENSES.chromium.html \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSES.chromium.html
+
+
+ # Remove unnecessary files
+ rm -rf "$srcdir"/usr/share/doc
+
+ # Install files and binary
+ cp -rT "$srcdir"/usr "$pkgdir"/usr
+ cp -rT "$srcdir"/opt/bootstrapstudio "$pkgdir"/usr/lib/$pkgname
+
+ # Symlink binary
+ ln -s /usr/lib/$pkgname/'Bootstrap Studio' "$pkgdir"/usr/bin/$pkgname
+
+ # Fix permission
+ chmod -R go-w "$pkgdir"
}
diff --git a/bootstrap-studio.install b/bootstrap-studio.install
deleted file mode 100644
index 4c65bb037857..000000000000
--- a/bootstrap-studio.install
+++ /dev/null
@@ -1,26 +0,0 @@
-# Some colored makepkg-like functions
-msg_blue()
-{
- printf "${BLUE}==>${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
-}
-
-note_blue()
-{
- printf "${BLUE}==>${ALL_OFF}${BOLD} NOTE${1}:${ALL_OFF} ${2}\n"
-}
-
-ALL_OFF="$(tput sgr0)"
-BOLD="$(tput bold)"
-BLUE="${BOLD}$(tput setaf 4)"
-GREEN="${BOLD}$(tput setaf 2)"
-
-post_install()
-{
- mkdir -p /usr/local/bin
- ln -sr /opt/bootstrapstudio/Bootstrap\ Studio /usr/local/bin/bootstrap-studio
-}
-
-post_upgrade()
-{
- post_install
-}