summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHunter Wittenborn2021-05-25 01:58:19 -0500
committerHunter Wittenborn2021-05-25 01:58:19 -0500
commit6a9ddff83e9b21f41bdc2a93e0b1e75113dc7a30 (patch)
treea343f26439bdb0cc0c927771f690914b11ff58eb
parent0b1951f79fb558ea278efa9adf1f0a5c0e41f050 (diff)
downloadaur-6a9ddff83e9b21f41bdc2a93e0b1e75113dc7a30.tar.gz
Fixed permission issue; Created symlink from '/usr/bin/bootstrap-studio' to '/opt/bootstrap-studio/AppRun'
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64aee4de9451..8b180a0d7c1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=bootstrap-studio
pkgver=5.6.2
-pkgrel=2
+pkgrel=3
pkgdesc="Bootstrap Studio is a powerful tool which web developers and designers use to create layouts and fully functional websites using the Bootstrap framework."
arch=("x86_64")
license=("custom")
@@ -16,19 +16,23 @@ sha256sums=("SKIP"
"SKIP")
prepare() {
+ # Extract AppImage
+ echo "Extracting AppImage..."
chmod +x "Bootstrap Studio.AppImage"
- ./"Bootstrap Studio.AppImage" --appimage-extract
+ ./"Bootstrap Studio.AppImage" --appimage-extract &> /dev/null
}
package() {
# Copy package files
+ echo "Copying package files..."
mkdir -p "${pkgdir}/opt/bootstrap-studio"
cp -Lr "${srcdir}/squashfs-root" "${pkgdir}/opt/bootstrap-studio"
+ # Set perms
+ chmod a+r "${pkgdir}/opt/bootstrap-studio" -R
# Add package to /usr/bin/
mkdir -p "${pkgdir}/usr/bin"
- echo '#!/usr/bin/env bash
- gtk-launch bstudio.desktop' | tee "${pkgdir}/usr/bin/bootstrap-studio"
+ printf '#!/bin/bash\n\n/opt/bootstrap-studio/AppRun' | tee "${pkgdir}/usr/bin/bootstrap-studio" &> /dev/null
chmod +x "${pkgdir}/usr/bin/bootstrap-studio"
# Copy .desktop file