summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYohann D'ANELLO2021-04-06 18:12:37 +0200
committerYohann D'ANELLO2021-04-06 18:12:37 +0200
commit923cb18e36277e78d611e3d67cf61b1b43c71449 (patch)
tree65976b1864e4fb4c2e68ea68c30e6a3e46034a6d
downloadaur-923cb18e36277e78d611e3d67cf61b1b43c71449.tar.gz
Add bootstrap5
Signed-off-by: Yohann D'ANELLO <ynerant@crans.org>
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD29
-rw-r--r--bootstrap.install5
5 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ed16947da93
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bootstrap5
+ pkgdesc = Front-end framework for web development
+ pkgver = 5.0.0b3
+ pkgrel = 1
+ url = https://getbootstrap.com/
+ install = bootstrap.install
+ arch = any
+ license = MIT
+ source = https://github.com/twbs/bootstrap/releases/download/v5.0.0-beta3/bootstrap-5.0.0-beta3-dist.zip
+ source = LICENSE
+ sha256sums = 1c1d512fb0d59997a7fb12a340f1bb63f2827dd490e742aeea138b4fcf16bb2b
+ sha256sums = 5b30317c9c35bb6f05101c501de866cc6852ab9b655dcf5941733f6644c3ebd0
+
+pkgname = bootstrap5
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d5bf3770ca57
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+
+*.zip
+*.zst
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..72dda234edaa
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+The MIT License (MIT)
+
+Copyright (c) 2011-2021 Twitter, Inc.
+Copyright (c) 2011-2021 The Bootstrap Authors
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b64c9436642b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Yohann D'Anello <ynerant [at] crans [dot] org>
+
+pkgname=bootstrap5
+pkgver=5.0.0b3
+# During beta, store full version number with the dash
+pkgfullver=5.0.0-beta3
+pkgrel=1
+pkgdesc="Front-end framework for web development"
+arch=('any')
+url="https://getbootstrap.com/"
+license=('MIT')
+optdepends=()
+install=bootstrap.install
+source=("https://github.com/twbs/bootstrap/releases/download/v${pkgfullver}/bootstrap-${pkgfullver}-dist.zip"
+ "LICENSE")
+sha256sums=('1c1d512fb0d59997a7fb12a340f1bb63f2827dd490e742aeea138b4fcf16bb2b'
+ '5b30317c9c35bb6f05101c501de866cc6852ab9b655dcf5941733f6644c3ebd0')
+
+package() {
+ cd bootstrap-${pkgfullver}-dist
+ install -d ${pkgdir}/usr/share/javascript/${pkgname}/{css,js}
+ for _jsfile in ./js/*; do
+ install -m0644 "${_jsfile}" "${pkgdir}/usr/share/javascript/${pkgname}/js/"
+ done
+ for _cssfile in ./css/*; do
+ install -m0644 "${_cssfile}" "${pkgdir}/usr/share/javascript/${pkgname}/css/"
+ done
+ install -Dm0644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/bootstrap.install b/bootstrap.install
new file mode 100644
index 000000000000..fa3df3a6f1e4
--- /dev/null
+++ b/bootstrap.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo
+ echo "See https://getbootstrap.com/docs for getting started with Bootstrap"
+ echo
+}