summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopolon2020-12-14 19:09:51 +0100
committerPopolon2020-12-14 19:09:51 +0100
commiteee2214a7e0815d8b81eeb8f829f99d9c88b73af (patch)
tree2a7a6b09167063a640f1828f2522c0300a58e48d
downloadaur-eee2214a7e0815d8b81eeb8f829f99d9c88b73af.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..039344205b45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bootterm
+ pkgdesc = Simple, reliable and powerful terminal designed to ease connection to ephemeral serial ports
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/wtarreau/bootterm/
+ arch = x86_64
+ arch = armv7h
+ arch = armv8
+ license = MIT
+ source = https://github.com/wtarreau/bootterm/archive/v0.1.tar.gz
+ sha256sums = 3c35ffef75dfc3e59552fd999114005b8fdf40fd85619ec9d93458c048987a82
+
+pkgname = bootterm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4048ac465f8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Popolon <popolon@popolon.org>
+
+pkgname=bootterm
+pkgver=0.1
+pkgrel=1
+pkgdesc="Simple, reliable and powerful terminal designed to ease connection to ephemeral serial ports"
+arch=('x86_64' 'armv7h' 'armv8')
+url="https://github.com/wtarreau/bootterm/"
+license=('MIT')
+source=(https://github.com/wtarreau/$pkgname/archive/v${pkgver}.tar.gz)
+sha256sums=('3c35ffef75dfc3e59552fd999114005b8fdf40fd85619ec9d93458c048987a82')
+
+build() {
+ cd $pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make install DESTDIR="$pkgdir" PREFIX=/usr
+}