summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Jaksch2021-01-19 06:03:17 +0100
committerOliver Jaksch2021-01-19 06:03:17 +0100
commit277e714f748782593738a85fe4e8f5af3405b6e0 (patch)
tree099ab64c5552fd5cd44cd2fc854c198b90a8fd1e
parent12758b5d6c320b49e3d5923382f35dd49aa98c52 (diff)
downloadaur-277e714f748782593738a85fe4e8f5af3405b6e0.tar.gz
Update, icons and a .desktop file
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--borg-backup-gui.desktop15
3 files changed, 29 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bc0e0122531..01d8effc58eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = borg-backup-gui-git
pkgdesc = Borg BackUP GUI can be used by new Borg users to get to their destination very quickly.
- pkgver = 330.2111867
+ pkgver = 332.3701ec4
pkgrel = 1
url = https://github.com/MTrage/Borg-BackUP-GUI
arch = i686
@@ -11,7 +11,9 @@ pkgbase = borg-backup-gui-git
depends = qt5-base
optdepends = adwaita-icon-theme
source = git+https://github.com/MTrage/Borg-BackUP-GUI.git
+ source = borg-backup-gui.desktop
sha256sums = SKIP
+ sha256sums = 725dd8dd8b4cc837546c27bb179b7f80bc42339f8859ccf2189a676a82ed5c87
pkgname = borg-backup-gui-git
diff --git a/PKGBUILD b/PKGBUILD
index caa374ede991..84dc36e0c99e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Oliver Jaksch <arch-aur@com-in.de>
pkgname=borg-backup-gui-git
-pkgver=330.2111867
+pkgver=332.3701ec4
pkgrel=1
pkgdesc="Borg BackUP GUI can be used by new Borg users to get to their destination very quickly."
url="https://github.com/MTrage/Borg-BackUP-GUI"
@@ -12,8 +12,10 @@ makedepends=('git')
optdepends=('adwaita-icon-theme')
_gitname=Borg-BackUP-GUI
-source=("git+https://github.com/MTrage/${_gitname}.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/MTrage/${_gitname}.git"
+ 'borg-backup-gui.desktop')
+sha256sums=('SKIP'
+ '725dd8dd8b4cc837546c27bb179b7f80bc42339f8859ccf2189a676a82ed5c87')
pkgver() {
cd "${_gitname}/src"
@@ -29,4 +31,10 @@ build() {
package() {
cd "${_gitname}/src"
install -Dm755 "BORG-BackUP-GUI" "${pkgdir}/usr/bin/BORG-BackUP-GUI"
+ install -D -m 644 ${srcdir}/borg-backup-gui.desktop ${pkgdir}/usr/share/applications/borg-backup-gui.desktop
+ for icons in $(ls ../images/icons/); do
+ echo ${icons}
+ mkdir -p "${pkgdir}/usr/share/icons/hicolor/${icons}/apps"
+ cp ../images/icons/${icons}/BORG-BackUP-GUI.* "${pkgdir}/usr/share/icons/hicolor/${icons}/apps/"
+ done
}
diff --git a/borg-backup-gui.desktop b/borg-backup-gui.desktop
new file mode 100644
index 000000000000..67df089fbd0e
--- /dev/null
+++ b/borg-backup-gui.desktop
@@ -0,0 +1,15 @@
+[Desktop Entry]
+Version=1.0
+Name=BORG BackUP GUI
+# Only KDE 4 seems to use GenericName, so we reuse the KDE strings.
+# From Ubuntu's language-pack-kde-XX-base packages, version 9.04-20090413.
+GenericName=Helps new Borg users to get to their destination very quickly
+# Gnome and KDE 3 uses Comment.
+Comment=Helps new Borg users to get to their destination very quickly
+Exec=/usr/bin/BORG-BackUP-GUI
+StartupNotify=true
+Terminal=false
+Icon=BORG-BackUP-GUI
+Type=Application
+Categories=Network;System;
+Actions=new-window;new-private-window;