summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2018-12-26 17:50:18 -0600
committerDan Beste2018-12-26 17:50:18 -0600
commit08538a6f07d0829b702a9a69b386f81d269a8d9d (patch)
treecdda8af57ce7f0a8cf95ca9558159435a440a9d2
parent8e053ea96d0b1e94de738527a2920d17e981558d (diff)
downloadaur-08538a6f07d0829b702a9a69b386f81d269a8d9d.tar.gz
upgpkg: borgmatic 1.2.14-3
Re-enable tests. It's a bit hacky, but it gets the job done... I'm open to suggestions if there's a simpler method to get them running.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD23
2 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a72710b2fbf..ef6da611f353 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = borgmatic
pkgdesc = A wrapper script for Borg backup software that creates and prunes backups
pkgver = 1.2.14
- pkgrel = 2
+ pkgrel = 3
url = https://torsion.org/borgmatic/
install = borgmatic.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 2ad10c483cbb..75f0a0436f91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='borgmatic'
pkgver=1.2.14
-pkgrel=1
+pkgrel=3
pkgdesc='A wrapper script for Borg backup software that creates and prunes backups'
arch=('any')
url='https://torsion.org/borgmatic/'
@@ -24,11 +24,22 @@ sha256sums=(
'1b033f96dc7404c26fad0f5fbbdda2fd93959869a7737092049ed7cfe994602e'
)
-#check() {
-# cd "${pkgname}"
-#
-# pytest --ignore='./tests/end-to-end'
-#}
+_pytestdir="$(mktemp -d)"
+
+prepare() {
+ cd "${pkgname}"
+
+ python setup.py -q install --root="${_pytestdir}"
+}
+
+check() {
+ cd "${pkgname}"
+
+ export PATH="${PATH}:${_pytestdir}/usr/bin"
+ export PYTHONPATH="${PYTHONPATH}:${_pytestdir}/usr/lib/python*/site-packages/"
+
+ pytest
+}
package() {
cd "${pkgname}"