summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2018-08-04 16:28:38 -0500
committerDan Beste2018-08-04 16:29:11 -0500
commitd7bcd05314695d219fcebc5939be735671c09d33 (patch)
tree450e47499fb2a5d81c6768b020f485bdc49a8cda
parent6576d28f76d058188102a0d327d275bfcbc44096 (diff)
downloadaur-d7bcd05314695d219fcebc5939be735671c09d33.tar.gz
upgpkg: borgmatic 1.2.1-1
PKGBUILD cleanup + version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 7 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9602c40edf99..96b8892f1ebe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = borgmatic
pkgdesc = A wrapper script for Borg backup software that creates and prunes backups
- pkgver = 1.2.0
- pkgrel = 2
+ pkgver = 1.2.1
+ pkgrel = 1
url = https://torsion.org/borgmatic/
install = borgmatic.install
arch = any
@@ -12,9 +12,9 @@ pkgbase = borgmatic
depends = borg
depends = python-pykwalify
depends = python-ruamel-yaml
- source = borgmatic-1.2.0.tar.gz::https://projects.torsion.org/witten/borgmatic/archive/1.2.0.tar.gz
+ source = borgmatic-1.2.1.tar.gz::https://projects.torsion.org/witten/borgmatic/archive/1.2.1.tar.gz
source = borgmatic.install
- sha256sums = f5ff0e8676637b7ad28b559f70f0fe33d8fa67b2b28e41f078ae71a7869a50d2
+ sha256sums = abe7b092cce614f36369a93cdd50b3f4f9d775ccc5e8325acd93a791e767343a
sha256sums = 2862763feea83e3ee0fb65c9f3fec648312486cd8ab48cd7cac70a7bb742b55b
pkgname = borgmatic
diff --git a/PKGBUILD b/PKGBUILD
index 2428435ce3d5..b7f1fbf22195 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: stef204 <https://aur.archlinux.org/account/stef204>
pkgname='borgmatic'
-pkgver=1.2.0
-pkgrel=2
+pkgver=1.2.1
+pkgrel=1
pkgdesc='A wrapper script for Borg backup software that creates and prunes backups'
arch=('any')
url='https://torsion.org/borgmatic/'
@@ -17,36 +17,19 @@ source=(
"${pkgname}.install"
)
sha256sums=(
- 'f5ff0e8676637b7ad28b559f70f0fe33d8fa67b2b28e41f078ae71a7869a50d2'
+ 'abe7b092cce614f36369a93cdd50b3f4f9d775ccc5e8325acd93a791e767343a'
'2862763feea83e3ee0fb65c9f3fec648312486cd8ab48cd7cac70a7bb742b55b'
)
prepare() {
cd "${pkgname}"
- # Workaround for borgmatic requiring python-ruamel-yaml <= 15.0. This will
- # break when Arch's python-ruamel-yaml version exceeds 15. Long-term a
- # change should be proposed to address this upstream:
- #
- # https://tree.taiga.io/project/witten-borgmatic/issue/37
- #
- # We will welcome patches to maintain compatibility with Arch's
- # python-ruamel-yaml version if upstream is slow to adopt it.
- sed -i 's/ruamel.yaml<=0.15/ruamel.yaml<0.16/' setup.py
sed -i 's#/usr/local/bin/borgmatic#/usr/bin/borgmatic#' sample/systemd/borgmatic.service
}
check() {
cd "${pkgname}"
- # Required because borgmatic uses python 3.4, but Arch's default python
- # version is 3.6. Once borgmatic moves to 3.6 upstream, this workaround
- # should be removed.
- #
- # Again, if patches are required to maintain compatibility with Arch's
- # python version, we will gladly accept them.
- sed -i 's/envlist=py34/envlist=py36/' tox.ini
-
pytest
}