summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-11-07 13:15:00 -0600
committerDan Beste2017-11-07 13:15:00 -0600
commite7fce1538f4e78f695ffaf3590e4c3e70f85d64b (patch)
tree3e84a74f78a64c7f39306cf51125978212eeb226
parentea18acfc888a42e7822cfd486a2e4743e2c26832 (diff)
downloadaur-e7fce1538f4e78f695ffaf3590e4c3e70f85d64b.tar.gz
v1.1.11
* PKGBUILD: Upstream has switched to gittea, and the archives were mangled. This necessitated a switch to using the git repository and relevant commit IDs for the time being. * borgmatic.install: formatting & spelling improvements.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--borgmatic.install22
3 files changed, 29 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 872b13dbc23c..533bc2857928 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = borgmatic
pkgdesc = A wrapper script for Borg backup software that creates and prunes backups
- pkgver = 1.1.7
- pkgrel = 4
+ pkgver = 1.1.11
+ pkgrel = 1
url = https://torsion.org/borgmatic/
install = borgmatic.install
arch = any
@@ -12,10 +12,10 @@ pkgbase = borgmatic
depends = python-pykwalify
depends = python-ruamel-yaml
provides = borgmatic
- source = borgmatic-1.1.7.tar.gz::https://torsion.org/hg/borgmatic/archive/1.1.7.tar.gz
+ source = git+https://projects.torsion.org/witten/borgmatic.git#commit=425e27dee5443e3121d18340b990974a6de51071
source = borgmatic.install
- sha256sums = 939ae88c8f9d2caf77b29a1bb9a53df52fc274ed6f004793616da0c6dab73eae
- sha256sums = ca30f277f9ea3663e61a94e898fcbc3bd34073fdbb37da3f18ebb42a04ec0381
+ sha256sums = SKIP
+ sha256sums = 2862763feea83e3ee0fb65c9f3fec648312486cd8ab48cd7cac70a7bb742b55b
pkgname = borgmatic
diff --git a/PKGBUILD b/PKGBUILD
index 5ea29009ed83..44d965f16bea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: stef204 <https://aur.archlinux.org/account/stef204>
pkgname='borgmatic'
-pkgver=1.1.7
-pkgrel=4
+pkgver=1.1.11
+pkgrel=1
pkgdesc='A wrapper script for Borg backup software that creates and prunes backups'
arch=('any')
url='https://torsion.org/borgmatic/'
@@ -13,13 +13,15 @@ depends=('borg' 'python-pykwalify' 'python-ruamel-yaml')
makedepends=('python-setuptools' 'python-tox')
provides=('borgmatic')
install="${pkgname}.install"
-source=("${pkgname}-${pkgver}.tar.gz::https://torsion.org/hg/${pkgname}/archive/${pkgver}.tar.gz"
+# Main repository moved over to gittea. Switch to using commits until tags are
+# fixed:
+source=('git+https://projects.torsion.org/witten/borgmatic.git#commit=425e27dee5443e3121d18340b990974a6de51071'
"${pkgname}.install")
-sha256sums=('939ae88c8f9d2caf77b29a1bb9a53df52fc274ed6f004793616da0c6dab73eae'
- 'ca30f277f9ea3663e61a94e898fcbc3bd34073fdbb37da3f18ebb42a04ec0381')
+sha256sums=('SKIP'
+ '2862763feea83e3ee0fb65c9f3fec648312486cd8ab48cd7cac70a7bb742b55b')
prepare() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}"
# Workaround for borgmatic requiring python-ruamel-yaml <= 15.0. This will
# break when Arch's python-ruamel-yaml version exceeds 15. Long-term a
@@ -34,7 +36,7 @@ prepare() {
}
check() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}"
# Required because borgmatic uses python 3.4, but Arch's default python
# version is 3.6. Once borgmatic moves to 3.6 upstream, this workaround
@@ -48,7 +50,7 @@ check() {
}
package() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}"
python setup.py -q install --root="${pkgdir}" --optimize=1
diff --git a/borgmatic.install b/borgmatic.install
index dfb5131ee7e0..40ba1e2389aa 100644
--- a/borgmatic.install
+++ b/borgmatic.install
@@ -1,13 +1,19 @@
post_install() {
- echo ">>> WARNING: If you are updateing from a 1.0.x release you should run:"
- echo ">>> sudo upgrade-borgmatic-config"
- echo ">>> to convert your config from ini to yaml format."
- echo ">>> For more information read at: https://torsion.org/borgmatic/"
+ echo " WARNING: If you are updating from a 1.0.x release you should run:"
+ echo ""
+ echo " sudo upgrade-borgmatic-config"
+ echo ""
+ echo " to convert your config from ini to yaml format."
+ echo " For more information: https://torsion.org/borgmatic/"
}
post_upgrade() {
- echo ">>> WARNING: If you are updateing from a 1.0.x release you should run:"
- echo ">>> sudo upgrade-borgmatic-config"
- echo ">>> to convert your config from ini to yaml format."
- echo ">>> For more information read at: https://torsion.org/borgmatic/"
+ echo " WARNING: If you are updating from a 1.0.x release you should run:"
+ echo ""
+ echo " sudo upgrade-borgmatic-config"
+ echo ""
+ echo " To convert your config from ini to yaml format."
+ echo " For more information: https://torsion.org/borgmatic/"
}
+
+# vim: ts=2 sw=2 et: