summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2018-04-14 19:09:17 -0500
committerDan Beste2018-04-14 19:09:17 -0500
commitf110b77eab9b63e3736263c5180a09f60300946d (patch)
tree7cc0eafa9e52b81ce15853469e362fb275620fb7
parent2f40177dab7952ce04d58cca4bb2b84a94986cf4 (diff)
downloadaur-f110b77eab9b63e3736263c5180a09f60300946d.tar.gz
Various PKGBUILD updates
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 3 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb1f9c7cfb42..4341669bbe2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,14 +6,12 @@ pkgbase = borgmatic
install = borgmatic.install
arch = any
license = GPL3
- makedepends = git
makedepends = python-setuptools
- makedepends = python-tox
makedepends = python-flexmock
+ makedepends = python-pytest
depends = borg
depends = python-pykwalify
depends = python-ruamel-yaml
- provides = borgmatic
source = borgmatic-1.1.15.tar.gz::https://projects.torsion.org/witten/borgmatic/archive/1.1.15.tar.gz
source = borgmatic.install
sha256sums = d926baee7ec7a374785cdee124c56f6270e8273fc0d1f91299b7fbe2cb04aab2
diff --git a/PKGBUILD b/PKGBUILD
index 9e2d26dc324e..e4bdad066fbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,7 @@ arch=('any')
url='https://torsion.org/borgmatic/'
license=('GPL3')
depends=('borg' 'python-pykwalify' 'python-ruamel-yaml')
-makedepends=('git' 'python-setuptools' 'python-tox' 'python-flexmock')
-provides=('borgmatic')
+makedepends=('python-setuptools' 'python-flexmock' 'python-pytest')
install="${pkgname}.install"
source=(
"${pkgname}-${pkgver}.tar.gz::https://projects.torsion.org/witten/borgmatic/archive/${pkgver}.tar.gz"
@@ -48,7 +47,7 @@ check() {
# python version, we will gladly accept them.
sed -i 's/envlist=py34/envlist=py36/' tox.ini
- tox
+ pytest
}
package() {