summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquininer2019-03-27 23:37:15 +0800
committerquininer2019-03-27 23:37:15 +0800
commit94793e4552f79dcf40a636fb0ac796eb69f2dfb1 (patch)
tree2f701ec4d7e946114d3f65589b5c82d4c7341bc6
downloadaur-94793e4552f79dcf40a636fb0ac796eb69f2dfb1.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff1eb1a67266
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = boringtun-git
+ pkgdesc = Userspace WireGuard® Implementation in Rust
+ pkgver = 0.2.0.9.g201682d
+ pkgrel = 1
+ url = https://github.com/cloudflare/boringtun
+ arch = x86_64
+ arch = i686
+ license = BSD-3-Clause
+ makedepends = cargo
+ makedepends = git
+ provides = boringtun
+ conflicts = boringtun
+ source = boringtun-git::git+https://github.com/cloudflare/boringtun
+ sha256sums = SKIP
+
+pkgname = boringtun-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01b0935ecfba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=boringtun-git
+pkgver=0.2.0.9.g201682d
+pkgrel=1
+pkgdesc="Userspace WireGuard® Implementation in Rust"
+arch=('x86_64' 'i686')
+url="https://github.com/cloudflare/boringtun"
+license=('BSD-3-Clause')
+depends=()
+makedepends=('cargo' 'git')
+optdepends=()
+provides=('boringtun')
+conflicts=('boringtun')
+source=($pkgname::git+https://github.com/cloudflare/boringtun)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD).g$(git describe --always)
+}
+
+build() {
+ cd $pkgname
+ cargo build --release
+}
+
+package() {
+ cd $pkgname
+ install -D -m755 "$srcdir/$pkgname/target/release/boringtun" "$pkgdir/usr/bin/boringtun"
+}