summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBin Jin2019-06-27 20:39:47 +0000
committerBin Jin2019-06-28 04:39:47 +0800
commite8fbaf4922f21f062f731f4a3529d727ad3cefd7 (patch)
tree343292d7c8023a59bbedf1033ccf2f46c41b05f5
parent94793e4552f79dcf40a636fb0ac796eb69f2dfb1 (diff)
downloadaur-e8fbaf4922f21f062f731f4a3529d727ad3cefd7.tar.gz
fix broken pkgver()
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD12
3 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff1eb1a67266..62ead60ab92a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = boringtun-git
pkgdesc = Userspace WireGuard® Implementation in Rust
- pkgver = 0.2.0.9.g201682d
+ pkgver = 0.2.0.8.g37be474
pkgrel = 1
url = https://github.com/cloudflare/boringtun
arch = x86_64
arch = i686
+ arch = aarch64
license = BSD-3-Clause
makedepends = cargo
makedepends = git
+ depends = gcc-libs
+ optdepends = wireguard-tools: tools and scripts for interface setup
provides = boringtun
conflicts = boringtun
- source = boringtun-git::git+https://github.com/cloudflare/boringtun
+ source = boringtun-git::git+https://github.com/cloudflare/boringtun.git
sha256sums = SKIP
pkgname = boringtun-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b7c23def257f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/boringtun-git
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 01b0935ecfba..d2ca37683345 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
pkgname=boringtun-git
-pkgver=0.2.0.9.g201682d
+pkgver=0.2.0.8.g37be474
pkgrel=1
pkgdesc="Userspace WireGuard® Implementation in Rust"
-arch=('x86_64' 'i686')
+arch=('x86_64' 'i686' 'aarch64')
url="https://github.com/cloudflare/boringtun"
license=('BSD-3-Clause')
-depends=()
+depends=('gcc-libs')
makedepends=('cargo' 'git')
-optdepends=()
+optdepends=('wireguard-tools: tools and scripts for interface setup')
provides=('boringtun')
conflicts=('boringtun')
-source=($pkgname::git+https://github.com/cloudflare/boringtun)
+source=($pkgname::git+https://github.com/cloudflare/boringtun.git)
sha256sums=('SKIP')
pkgver() {
cd $pkgname
- echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD).g$(git describe --always)
+ echo "$(git describe --long --tags | sed 's/^v//;s/-/./g')"
}
build() {