summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Wild2019-02-24 15:58:15 -0500
committerAllen Wild2019-02-24 15:58:15 -0500
commit0ba68528415cb1c3ab7a574aafe59548920b7494 (patch)
tree7a8aa3488eca1628e0b8f741f21aff53e7e411be
parent82b05afea76ba16036dc0f580db996303a5669c3 (diff)
downloadaur-0ba68528415cb1c3ab7a574aafe59548920b7494.tar.gz
v1.9.1.r2.g3279031-1: don't override version during make, bossac patch for -V/--version
Upstream now includes the git revision in bossa's version string so there's no need to override in the PKGBUILD. Include my PR patch to add a -V/--version option to bossac.
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
3 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5063ccfa112e..a315bd7ded43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bossa-git
pkgdesc = Flash programming utility for Atmel's SAM family of flash-based ARM microcontrollers
- pkgver = 1.8.r48.gb176eee
- pkgrel = 2
+ pkgver = 1.9.1.r2.g3279031
+ pkgrel = 1
url = https://github.com/shumatech/BOSSA
arch = i686
arch = x86_64
@@ -12,8 +12,10 @@ pkgbase = bossa-git
conflicts = bossa
source = git://github.com/shumatech/BOSSA
source = arduino-reset.patch::https://github.com/shumatech/BOSSA/pull/78.patch
+ source = version-option.patch::https://github.com/shumatech/BOSSA/pull/92.patch
sha256sums = SKIP
sha256sums = da2571b32da6dd7212654efb96aa7f17a80790e695118f8a13847ffca62de294
+ sha256sums = b38f5680f20e456652822714c758184524e41ac27e85716212951f8a6306c807
pkgname = bossa-git
diff --git a/.gitignore b/.gitignore
index d9e15ccb93e8..674caef92509 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
/arduino-reset.patch
+/version-option.patch
/pkg/
/src/
/BOSSA/
diff --git a/PKGBUILD b/PKGBUILD
index 65e179580c69..4fb6dddda1fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Allen Wild <allenwild93@gmail.com>
# Contributor: Matt Coffin <mcoffin13@gmail.com>
pkgname=bossa-git
-pkgver=1.8.r48.gb176eee
-pkgrel=2
+pkgver=1.9.1.r2.g3279031
+pkgrel=1
pkgdesc="Flash programming utility for Atmel's SAM family of flash-based ARM microcontrollers"
arch=('i686' 'x86_64')
url="https://github.com/shumatech/BOSSA"
@@ -11,9 +11,11 @@ depends=('readline' 'wxgtk')
provides=('bossa')
conflicts=('bossa')
source=("git://github.com/shumatech/BOSSA"
- "arduino-reset.patch::https://github.com/shumatech/BOSSA/pull/78.patch")
+ "arduino-reset.patch::https://github.com/shumatech/BOSSA/pull/78.patch"
+ "version-option.patch::https://github.com/shumatech/BOSSA/pull/92.patch")
sha256sums=('SKIP'
- 'da2571b32da6dd7212654efb96aa7f17a80790e695118f8a13847ffca62de294')
+ 'da2571b32da6dd7212654efb96aa7f17a80790e695118f8a13847ffca62de294'
+ 'b38f5680f20e456652822714c758184524e41ac27e85716212951f8a6306c807')
pkgver() {
cd "$srcdir/BOSSA"
@@ -23,11 +25,12 @@ pkgver() {
prepare() {
cd "$srcdir/BOSSA"
patch -p1 -i "$srcdir/arduino-reset.patch"
+ patch -p1 -i "$srcdir/version-option.patch"
}
build() {
cd "$srcdir/BOSSA"
- make VERSION="$pkgver-$pkgrel"
+ make
}
package() {