summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Wild2018-06-15 18:32:14 -0400
committerAllen Wild2018-06-15 18:32:14 -0400
commit6cc2ce0d003f81045b5ee6957972b2c689fa3295 (patch)
tree20f283fb6ae9776e742685f9a5794872d274a06b
parentdf6f9b2075a54621c9a20ab8bd306b645a3c07d9 (diff)
downloadaur-6cc2ce0d003f81045b5ee6957972b2c689fa3295.tar.gz
Add patch to fix Arduino 1200 baud reset hack
https://github.com/shumatech/BOSSA/pull/78
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5947afe7376..803db8253e12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bossa-git
pkgdesc = Flash programming utility for Atmel's SAM family of flash-based ARM microcontrollers
pkgver = 1.8.r48.gb176eee
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/shumatech/BOSSA
arch = i686
arch = x86_64
@@ -11,7 +11,9 @@ pkgbase = bossa-git
provides = bossa
conflicts = bossa
source = git://github.com/shumatech/BOSSA
+ source = arduino-reset.patch::https://github.com/shumatech/BOSSA/commit/c704f9f2442bc49aa05c9f268637734d2c6712f0.patch
sha256sums = SKIP
+ sha256sums = da2571b32da6dd7212654efb96aa7f17a80790e695118f8a13847ffca62de294
pkgname = bossa-git
diff --git a/PKGBUILD b/PKGBUILD
index cebd674b8b09..b653e420921a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Matt Coffin <mcoffin13@gmail.com>
pkgname=bossa-git
pkgver=1.8.r48.gb176eee
-pkgrel=1
+pkgrel=2
pkgdesc="Flash programming utility for Atmel's SAM family of flash-based ARM microcontrollers"
arch=('i686' 'x86_64')
url="https://github.com/shumatech/BOSSA"
@@ -10,17 +10,25 @@ license=('BSD')
depends=('readline' 'wxgtk')
provides=('bossa')
conflicts=('bossa')
-source=("git://github.com/shumatech/BOSSA")
-sha256sums=('SKIP')
+source=("git://github.com/shumatech/BOSSA"
+ # https://github.com/shumatech/BOSSA/pull/78
+ "arduino-reset.patch::https://github.com/shumatech/BOSSA/commit/c704f9f2442bc49aa05c9f268637734d2c6712f0.patch")
+sha256sums=('SKIP'
+ 'da2571b32da6dd7212654efb96aa7f17a80790e695118f8a13847ffca62de294')
pkgver() {
cd "$srcdir/BOSSA"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/BOSSA"
+ patch -p1 -i "$srcdir/arduino-reset.patch"
+}
+
build() {
cd "$srcdir/BOSSA"
- make VERSION="$pkgver"
+ make VERSION="$pkgver-$pkgrel"
}
package() {