summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Coffin2016-12-03 00:09:59 -0700
committerMatt Coffin2016-12-03 00:09:59 -0700
commitb690610418fc3a59dc603be4ef6ab684011c1636 (patch)
tree9385ff39d812f8cc9ee2f919f531a0a41121a3a6
downloadaur-b690610418fc3a59dc603be4ef6ab684011c1636.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95dae27704cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bossa
+ pkgdesc = Flash programming utility for Atmel's SAM family of flash-based ARM microcontrollers
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = https://github.com/shumatech/BOSSA
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = readline
+ depends = wxgtk
+ source = https://github.com/shumatech/BOSSA/archive/1.7.0.tar.gz
+ sha256sums = 758ddaa70163561de9877d2f0f61dd64b51616273ac8709278d7e67ab90a6af3
+
+pkgname = bossa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bba1a1875abf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Matt Coffin <mcoffin13@gmail.com>
+pkgname=bossa
+pkgver=1.7.0
+pkgrel=1
+pkgdesc="Flash programming utility for Atmel's SAM family of flash-based ARM microcontrollers"
+arch=('i686' 'x86_64')
+url="https://github.com/shumatech/BOSSA"
+license=('BSD')
+depends=('readline' 'wxgtk')
+source=("https://github.com/shumatech/BOSSA/archive/$pkgver.tar.gz")
+sha256sums=('758ddaa70163561de9877d2f0f61dd64b51616273ac8709278d7e67ab90a6af3')
+
+build() {
+ cd "$srcdir/BOSSA-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/BOSSA-$pkgver"
+ mkdir -p "$pkgdir/usr/bin"
+ cp bin/bossa* "$pkgdir/usr/bin/"
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/BSD-3-Clause"
+}
+
+# vim:set ts=2 sw=2 et: