summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Wild2018-06-15 18:22:31 -0400
committerAllen Wild2018-06-15 18:22:31 -0400
commitdf6f9b2075a54621c9a20ab8bd306b645a3c07d9 (patch)
tree8b6eb714c6f8d194e2fd9de91ab834168305978b
parent422fcd753acfdc99f97fb5452afb3fd6af1be747 (diff)
downloadaur-df6f9b2075a54621c9a20ab8bd306b645a3c07d9.tar.gz
Initial commit of bossa-git, based on bossa-1.8-1
The version in the code is 1.9, but there's no format release tag in the repo so pkgver is 1.8.rXX.gYYYYYYY, and the Arch version is compiled into the code.
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD29
3 files changed, 31 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fb3544302e2..d5947afe7376 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = bossa
+pkgbase = bossa-git
pkgdesc = Flash programming utility for Atmel's SAM family of flash-based ARM microcontrollers
- pkgver = 1.8
+ pkgver = 1.8.r48.gb176eee
pkgrel = 1
url = https://github.com/shumatech/BOSSA
arch = i686
@@ -8,8 +8,10 @@ pkgbase = bossa
license = BSD
depends = readline
depends = wxgtk
- source = https://github.com/shumatech/BOSSA/archive/1.8.tar.gz
- sha256sums = ddfdb6a76cda61ccc372773ec63bd6b4e8b3a39824984c711346a52f27fbffea
+ provides = bossa
+ conflicts = bossa
+ source = git://github.com/shumatech/BOSSA
+ sha256sums = SKIP
-pkgname = bossa
+pkgname = bossa-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0847b03883b6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/pkg/
+/src/
+/BOSSA/
+*.pkg.tar.xz
+*.swp
+*~
diff --git a/PKGBUILD b/PKGBUILD
index 16bd34a694f3..cebd674b8b09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
-# Maintainer: Matt Coffin <mcoffin13@gmail.com>
-pkgname=bossa
-pkgver=1.8
+# Maintainer: Allen Wild <allenwild93@gmail.com>
+# Contributor: Matt Coffin <mcoffin13@gmail.com>
+pkgname=bossa-git
+pkgver=1.8.r48.gb176eee
pkgrel=1
pkgdesc="Flash programming utility for Atmel's SAM family of flash-based ARM microcontrollers"
arch=('i686' 'x86_64')
url="https://github.com/shumatech/BOSSA"
license=('BSD')
depends=('readline' 'wxgtk')
-source=("https://github.com/shumatech/BOSSA/archive/$pkgver.tar.gz")
-sha256sums=('ddfdb6a76cda61ccc372773ec63bd6b4e8b3a39824984c711346a52f27fbffea')
+provides=('bossa')
+conflicts=('bossa')
+source=("git://github.com/shumatech/BOSSA")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/BOSSA"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
build() {
- cd "$srcdir/BOSSA-$pkgver"
- make
+ cd "$srcdir/BOSSA"
+ make VERSION="$pkgver"
}
package() {
- cd "$srcdir/BOSSA-$pkgver"
- mkdir -p "$pkgdir/usr/bin"
- cp bin/bossa* "$pkgdir/usr/bin/"
- install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/BSD-3-Clause"
+ cd "$srcdir/BOSSA"
+ install -Dm755 -t "$pkgdir/usr/bin/" bin/bossa*
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/BSD-3-Clause"
}
# vim:set ts=2 sw=2 et: