summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-07-03 19:16:11 +0800
committerChocobo12018-07-03 20:18:11 +0800
commit00f10389365180eb63765b3689df9b996f450244 (patch)
tree9687997e3e11bfea8efa3bc59618ffbfb9e1a34d
downloadaur-00f10389365180eb63765b3689df9b996f450244.tar.gz
newpkg: botan-git 2.7.0.r3.gf639dae0a-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..291d9ff0b331
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = botan-git
+ pkgdesc = Cryptography library written in C++
+ pkgver = 2.7.0.r3.gf639dae0a
+ pkgrel = 1
+ url = https://botan.randombit.net/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = python
+ depends = glibc
+ depends = zlib
+ provides = botan
+ conflicts = botan
+ options = staticlibs
+ source = git+https://github.com/randombit/botan.git
+ sha256sums = SKIP
+
+pkgname = botan-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c76c99397c91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=botan-git
+pkgver=2.7.0.r3.gf639dae0a
+pkgrel=1
+pkgdesc="Cryptography library written in C++"
+arch=('i686' 'x86_64')
+url="https://botan.randombit.net/"
+license=('BSD')
+depends=('glibc' 'zlib')
+makedepends=('git' 'python')
+provides=('botan')
+conflicts=('botan')
+options=('staticlibs')
+source=("git+https://github.com/randombit/botan.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "botan"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "botan"
+
+ ./configure.py \
+ --prefix="/usr" \
+ --with-zlib
+ make
+}
+
+check() {
+ cd "botan"
+
+ ./botan-test
+}
+
+package() {
+ cd "botan"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "license.txt" "$pkgdir/usr/share/licenses/botan/license.txt"
+}