summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2018-04-09 07:55:12 +0300
committerMantas Mikulėnas2018-04-09 07:55:12 +0300
commitc2196cfb28f41a23637473dec91632d70a046b63 (patch)
tree2f610ad48fd80f5363d5574451c5ac5440cc9716
downloadaur-c2196cfb28f41a23637473dec91632d70a046b63.tar.gz
import from [community]
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..069d87be8bfa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = botan1.10
+ pkgdesc = Crypto library written in C++ - old stable branch
+ pkgver = 1.10.17
+ pkgrel = 1
+ url = http://botan.randombit.net/
+ arch = x86_64
+ license = BSD
+ makedepends = python2
+ depends = gcc-libs
+ depends = sh
+ source = https://botan.randombit.net/releases/Botan-1.10.17.tgz
+ source = https://botan.randombit.net/releases/Botan-1.10.17.tgz.asc
+ validpgpkeys = 621DAF6411E1851C4CF9A2E16211EBF1EFBADFBC
+ sha512sums = a47cab3af113652247c8efc8b0f043eb62175eaa8554833d5fc3016ea94dbdd8aa722ab9b5226cc5f133afbcc088d54362111630eaa4594812c39925cc3c8649
+ sha512sums = SKIP
+
+pkgname = botan1.10
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7edeb4cce460
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: drakkan <nicola.murino@gmail.com>
+
+pkgname=botan1.10
+pkgver=1.10.17
+pkgrel=1
+pkgdesc='Crypto library written in C++ - old stable branch'
+license=('BSD')
+arch=('x86_64')
+url='http://botan.randombit.net/'
+depends=('gcc-libs' 'sh')
+makedepends=('python2')
+source=("https://botan.randombit.net/releases/Botan-${pkgver}.tgz"{,.asc})
+sha512sums=('a47cab3af113652247c8efc8b0f043eb62175eaa8554833d5fc3016ea94dbdd8aa722ab9b5226cc5f133afbcc088d54362111630eaa4594812c39925cc3c8649'
+ 'SKIP')
+validpgpkeys=('621DAF6411E1851C4CF9A2E16211EBF1EFBADFBC') # Botan Distribution Key
+
+build() {
+ cd "Botan-$pkgver"
+
+ python2 configure.py --prefix=/usr --enable-modules=cvc
+ make
+}
+
+package() {
+ cd "Botan-$pkgver"
+
+ make DESTDIR="$pkgdir/usr" install
+ find "$pkgdir/usr/share/doc" -type f -exec chmod 0644 {} \;
+ install -Dm644 doc/license.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: