summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Bunbury2020-09-03 23:54:56 +0100
committerAlan Bunbury2020-09-03 23:54:56 +0100
commitd9f24a234e9427eaf59203d7ea8eebfc49166059 (patch)
tree655edda3276a2bdeea8362c25417592cb7b2d73c
downloadaur-d9f24a234e9427eaf59203d7ea8eebfc49166059.tar.gz
initial commit of bother
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77b0872c8b7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bother
+ pkgdesc = Produce heightmaps using real-world elevation data (primarily for use in OpenTTD).
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/bunburya/bother
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/2e/09/6acd600a5f8cfb5c2539e0ad617b9502f91cb5381cc0ab1fb226873ab0a2/Bother-0.1.tar.gz
+ md5sums = 9e45f1ad50c251c542c9d8048177c36e
+
+pkgname = bother
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..215285e0d7d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: bunburya
+pkgname=bother
+pkgver=0.1
+pkgrel=1
+pkgdesc="Produce heightmaps using real-world elevation data (primarily for use in OpenTTD)."
+url="https://github.com/bunburya/bother"
+depends=('python')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=('https://files.pythonhosted.org/packages/2e/09/6acd600a5f8cfb5c2539e0ad617b9502f91cb5381cc0ab1fb226873ab0a2/Bother-0.1.tar.gz')
+md5sums=('9e45f1ad50c251c542c9d8048177c36e')
+
+build() {
+ cd $srcdir/Bother-0.1
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/Bother-0.1
+ python setup.py install --root="$pkgdir" --optimize=1
+}