summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-06-03 19:02:02 +0200
committerAlexander F. Rødseth2019-06-03 19:02:02 +0200
commit66e26e0b70f6ff2c84c813c9f36fb3bc232fc61f (patch)
treea212895157ddf61539f4840f5790732b0ab2bf08
parentedd6a9ed830b484945144e0f26b09ab7abad9fb6 (diff)
downloadaur-66e26e0b70f6ff2c84c813c9f36fb3bc232fc61f.tar.gz
New release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 377cb7d13e3e..ff5fa20c4cba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
# Generated by mksrcinfo v8
-# Mon Jun 3 11:45:59 UTC 2019
+# Mon Jun 3 17:01:50 UTC 2019
pkgbase = botsay
- pkgdesc = Like cowsay, but with randomly generated ASCII robots
- pkgver = 1.0.1
+ pkgdesc = Like cowsay, but with randomly generated ASCII robots and rainbow support
+ pkgver = 1.2.1
pkgrel = 1
url = https://github.com/xyproto/botsay
arch = x86_64
license = MIT
makedepends = git
makedepends = go
- source = git+https://github.com/xyproto/botsay#tag=v1.0.1
+ source = git+https://github.com/xyproto/botsay#tag=v1.2.1
md5sums = SKIP
pkgname = botsay
diff --git a/PKGBUILD b/PKGBUILD
index beae5cd6697a..aa29bbb29c58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=botsay
-pkgver=1.0.1
+pkgver=1.2.1
pkgrel=1
-pkgdesc='Like cowsay, but with randomly generated ASCII robots'
+pkgdesc='Like cowsay, but with randomly generated ASCII robots and rainbow support'
arch=(x86_64)
url='https://github.com/xyproto/botsay'
license=(MIT)
@@ -14,7 +14,11 @@ md5sums=('SKIP')
build() {
cd $pkgname
- go build -buildmode=pie -gccgoflags="-s -w $LDFLAGS"
+ go build \
+ -asmflags "all=-trimpath=$PWD" \
+ -buildmode=pie \
+ -gcflags "all=-trimpath=$PWD" \
+ -ldflags "-s -w -extldflags $LDFLAGS"
}
package() {