summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClementTsang2020-08-25 18:55:53 -0400
committerClementTsang2020-08-25 18:55:53 -0400
commit05ad5e5c11f6e95bbc7c185c84758b7702be6fc8 (patch)
treeb0316eb12ef3621e4284474bde6bfe7b2addbf6e
parent7cd76c5faffb69a1b71572638a0e3b0d1c46391c (diff)
downloadaur-05ad5e5c11f6e95bbc7c185c84758b7702be6fc8.tar.gz
0.4.6
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60b7742f9b7a..44f2c52fd58e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = bottom
pkgdesc = A cross-platform graphical process/system monitor with a customizable interface and a multitude of features.
- pkgver = 0.4.5
+ pkgver = 0.4.6
pkgrel = 0
url = https://github.com/ClementTsang/bottom
arch = x86_64
license = MIT
makedepends = cargo
provides = bottom
- conflicts = bottom-bin
- source = bottom-0.4.5.tar.gz::https://github.com/ClementTsang/bottom/releases/download/0.4.5/bottom_required_files.tar.gz
- sha512sums = 1d1585e036b45ade3c9093408b6dd935000a359214cebd9e49eace4b9983ba7a1ab39afd142d5889a8488635cd2794e10358e7b147e5f214196bd3c1fa62207e
+ source = bottom-0.4.6.tar.gz::https://github.com/ClementTsang/bottom/archive/0.4.6.tar.gz
+ sha512sums = 1aeccd5225eeb6d640df30f47798ee7cb7a8a27daac6dcf7cf9b85eefae33774b5c4718c8e46b678089d996e09810f4b3baae60587a3acc07fe91c22cec3fd38
pkgname = bottom
diff --git a/PKGBUILD b/PKGBUILD
index 31b0cc0f35f8..dda52cd6592b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,29 @@
# Maintainer: Clement Tsang (xoronth) <cjhtsang@uwaterloo.ca>
pkgname=bottom
-pkgver=0.4.5
+pkgver=0.4.6
pkgrel=0
pkgdesc="A cross-platform graphical process/system monitor with a customizable interface and a multitude of features."
provides=('bottom')
-conflicts=('bottom-bin')
makedepends=('cargo')
arch=('x86_64')
url="https://github.com/ClementTsang/bottom"
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ClementTsang/bottom/releases/download/$pkgver/bottom_required_files.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ClementTsang/bottom/archive/$pkgver.tar.gz")
license=('MIT')
-sha512sums=('1d1585e036b45ade3c9093408b6dd935000a359214cebd9e49eace4b9983ba7a1ab39afd142d5889a8488635cd2794e10358e7b147e5f214196bd3c1fa62207e')
+sha512sums=('1aeccd5225eeb6d640df30f47798ee7cb7a8a27daac6dcf7cf9b85eefae33774b5c4718c8e46b678089d996e09810f4b3baae60587a3acc07fe91c22cec3fd38')
build() {
+ cd $pkgname-$pkgver
cargo build --release --locked
}
+check() {
+ cd $pkgname-$pkgver
+ cargo test --release --locked
+}
+
package() {
+ cd $pkgname-$pkgver
+ install -Dm755 target/release/btm "$pkgdir/usr/bin/btm"
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
- cd "./target/release"
- install -Dm755 btm "$pkgdir/usr/bin/btm"
} \ No newline at end of file