summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClementTsang2020-04-08 20:22:15 -0400
committerClementTsang2020-04-08 20:22:15 -0400
commit6f6aebfcf4dd2a08c8035aea7706a1341769b84b (patch)
treedf161b7248515d37db18a4c506a6a4d966c7c163
parent6faef31e6ae62026de3008cad8a0272629821dc0 (diff)
downloadaur-6f6aebfcf4dd2a08c8035aea7706a1341769b84b.tar.gz
0.3.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6d83d32da24..57ee9c9d9ad9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = bottom
pkgdesc = A cross-platform graphical process/system monitor with a customizable interface and a multitude of features.
- pkgver = 0.2.2
- pkgrel = 2
+ pkgver = 0.3.0
+ pkgrel = 1
url = https://github.com/ClementTsang/bottom
arch = x86_64
license = MIT
makedepends = cargo
- source = bottom-0.2.2.tar.gz::https://github.com/ClementTsang/bottom/releases/download/0.2.2/bottom_source_code.tar.gz
- sha512sums = f857d54f8c6dd563718ecb260a0f020f24e3f90701f984f61e9bd726a20f4f05302446eed95d14faa860c566f3541e5246d1f96431a5e00b46712964ac29201a
+ source = bottom-0.3.0.tar.gz::https://github.com/ClementTsang/bottom/releases/download/0.3.0-2/bottom_required_files.tar.gz
+ sha512sums = a6d1c030f284851140a3ce0e0939bafb7bb5d07fc4810299a6f8af579ebf67ea5cdb4c05667fd7f423b64173e93386186971361be0fc56e6377e9266d755482e
pkgname = bottom
diff --git a/PKGBUILD b/PKGBUILD
index d8b7a4f2e0c2..b26926d4e343 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Clement Tsang (xoronth) <cjhtsang@uwaterloo.ca>
pkgname=bottom
-pkgver=0.2.2
-pkgrel=2
+pkgver=0.3.0
+pkgrel=1
pkgdesc="A cross-platform graphical process/system monitor with a customizable interface and a multitude of features."
makedepends=('cargo')
arch=('x86_64')
url="https://github.com/ClementTsang/bottom"
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ClementTsang/bottom/releases/download/$pkgver/bottom_source_code.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ClementTsang/bottom/releases/download/$pkgver-2/bottom_required_files.tar.gz")
license=('MIT')
-sha512sums=('f857d54f8c6dd563718ecb260a0f020f24e3f90701f984f61e9bd726a20f4f05302446eed95d14faa860c566f3541e5246d1f96431a5e00b46712964ac29201a')
+sha512sums=('a6d1c030f284851140a3ce0e0939bafb7bb5d07fc4810299a6f8af579ebf67ea5cdb4c05667fd7f423b64173e93386186971361be0fc56e6377e9266d755482e')
build() {
- cargo build --release
+ cargo build --release --locked
}
package() {
install -Dm644 "README.md" "$pkgdir/usr/share/doc/${pkgname}/README.md"
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
cd "./target/release"
- strip btm
install -Dm755 btm "$pkgdir/usr/bin/btm"
} \ No newline at end of file