summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClementTsang2020-11-20 23:00:18 -0500
committerClementTsang2020-11-20 23:00:18 -0500
commit85b8e85267286c92622a58673d4f74317e2cf24a (patch)
tree9a77fde9da45232acbd1a1477f44816896b83d45
parent09ecb8a927795edfa8fa3447b673b0a775643057 (diff)
downloadaur-85b8e85267286c92622a58673d4f74317e2cf24a.tar.gz
0.5.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a13e9dd83c1..1880234b7bfb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = bottom
pkgdesc = A cross-platform graphical process/system monitor with a customizable interface and a multitude of features.
- pkgver = 0.4.7
+ pkgver = 0.5.0
pkgrel = 0
url = https://github.com/ClementTsang/bottom
arch = x86_64
license = MIT
makedepends = cargo
provides = bottom
- source = bottom-0.4.7.tar.gz::https://github.com/ClementTsang/bottom/archive/0.4.7.tar.gz
- sha512sums = 53063cad1e3541803aa8a5da6f2042c037d9d2cb4203a6672f92fe55a6e101a383576413e3e1594e44b657c8737335bbdbd673121aa8590cec49f71dae0ba7de
+ source = bottom-0.5.0.tar.gz::https://github.com/ClementTsang/bottom/archive/0.5.0.tar.gz
+ sha512sums = 8676586b36a10a1df9f7d9238155dc78e17263607c6a47142af608b9af4db44a98f38c178073d8fa23182b8f0337fa55a58d76db91e5a0c684b4c71e5a265d28
pkgname = bottom
diff --git a/PKGBUILD b/PKGBUILD
index 576ffd3f0e7b..511bfa81abca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Clement Tsang (xoronth) <cjhtsang@uwaterloo.ca>
pkgname=bottom
-pkgver=0.4.7
+pkgver=0.5.0
pkgrel=0
pkgdesc="A cross-platform graphical process/system monitor with a customizable interface and a multitude of features."
provides=('bottom')
@@ -10,7 +10,7 @@ arch=('x86_64')
url="https://github.com/ClementTsang/bottom"
source=("$pkgname-$pkgver.tar.gz::https://github.com/ClementTsang/bottom/archive/$pkgver.tar.gz")
license=('MIT')
-sha512sums=('53063cad1e3541803aa8a5da6f2042c037d9d2cb4203a6672f92fe55a6e101a383576413e3e1594e44b657c8737335bbdbd673121aa8590cec49f71dae0ba7de')
+sha512sums=('8676586b36a10a1df9f7d9238155dc78e17263607c6a47142af608b9af4db44a98f38c178073d8fa23182b8f0337fa55a58d76db91e5a0c684b4c71e5a265d28')
build() {
cd $pkgname-$pkgver
@@ -19,11 +19,16 @@ build() {
check() {
cd $pkgname-$pkgver
- cargo test --release --locked
+ CARGO_HUSKY_DONT_INSTALL_HOOKS=true cargo test --release --locked
}
package() {
cd $pkgname-$pkgver
install -Dm755 target/release/btm "$pkgdir/usr/bin/btm"
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+
+ local target_dir=$(ls target/release/build/bottom-*/out/btm.bash | head -n1 | xargs dirname)
+ install -Dm644 "$target_dir"/_btm "$pkgdir/usr/share/zsh/site-functions/_btm"
+ install -Dm644 "$target_dir"/btm.bash "$pkgdir/usr/share/bash-completion/completions/btm"
+ install -Dm644 "$target_dir"/btm.fish "$pkgdir/usr/share/fish/vendor_completions.d/btm.fish"
} \ No newline at end of file