summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClementTsang2020-01-09 22:30:19 -0500
committerClementTsang2020-01-09 22:30:19 -0500
commit979e31be7b914d22f3da7fc8933939ebcd7d1b9e (patch)
tree2a8bf93c17b10f0578ae40d2396e56e1ff6e0cba
downloadaur-979e31be7b914d22f3da7fc8933939ebcd7d1b9e.tar.gz
Initial deploy.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36e0611b7e8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bottom
+ pkgdesc = A graphical top clone, written in Rust. Inspired by both gtop and gotop.
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/ClementTsang/bottom
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ source = bottom-0.1.1.tar.gz::https://github.com/ClementTsang/bottom/archive/v0.1.1.tar.gz
+ sha512sums = SKIP
+
+pkgname = bottom
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..113226b60bfb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Clement Tsang <cjhtsang@uwaterloo.ca>
+
+pkgname=bottom
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="A graphical top clone, written in Rust. Inspired by both gtop and gotop."
+makedepends=('rust' 'cargo')
+arch=('x86_64')
+url="https://github.com/ClementTsang/bottom"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ClementTsang/$pkgname/archive/v$pkgver.tar.gz")
+license=('MIT')
+sha512sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --target=x86_64-unknown-linux-gnu
+}
+
+check() {
+ cargo test --target=x86_64-unknown-linux-gnu --verbose
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 target/release/btm "$pkgdir/usr/bin/btm"
+} \ No newline at end of file