summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClementTsang2020-05-05 00:25:40 -0400
committerClementTsang2020-05-05 00:25:40 -0400
commite6cdf88be3ab566988e7a396113a07283d50caac (patch)
treee935e8ec6c1c8c845ea368688803875e2d7021a7
parent6f6aebfcf4dd2a08c8035aea7706a1341769b84b (diff)
downloadaur-e6cdf88be3ab566988e7a396113a07283d50caac.tar.gz
0.4.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57ee9c9d9ad9..63f421b691b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = bottom
pkgdesc = A cross-platform graphical process/system monitor with a customizable interface and a multitude of features.
- pkgver = 0.3.0
- pkgrel = 1
+ pkgver = 0.4.0
+ pkgrel = 0
url = https://github.com/ClementTsang/bottom
arch = x86_64
license = MIT
makedepends = cargo
- source = bottom-0.3.0.tar.gz::https://github.com/ClementTsang/bottom/releases/download/0.3.0-2/bottom_required_files.tar.gz
- sha512sums = a6d1c030f284851140a3ce0e0939bafb7bb5d07fc4810299a6f8af579ebf67ea5cdb4c05667fd7f423b64173e93386186971361be0fc56e6377e9266d755482e
+ source = bottom-0.4.0.tar.gz::https://github.com/ClementTsang/bottom/releases/download/0.4.0/bottom_required_files.tar.gz
+ sha512sums = 7afb26c2448a36e550211878d5e60863dbfd9abdecb298985e20984299fb9954cc4e71fd94bdd9e8139cd837e1977fca3408873ee5e8223874d7048d9813a305
pkgname = bottom
diff --git a/PKGBUILD b/PKGBUILD
index b26926d4e343..cba28fad55cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Clement Tsang (xoronth) <cjhtsang@uwaterloo.ca>
pkgname=bottom
-pkgver=0.3.0
-pkgrel=1
+pkgver=0.4.0
+pkgrel=0
pkgdesc="A cross-platform graphical process/system monitor with a customizable interface and a multitude of features."
makedepends=('cargo')
arch=('x86_64')
url="https://github.com/ClementTsang/bottom"
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ClementTsang/bottom/releases/download/$pkgver-2/bottom_required_files.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ClementTsang/bottom/releases/download/$pkgver/bottom_required_files.tar.gz")
license=('MIT')
-sha512sums=('a6d1c030f284851140a3ce0e0939bafb7bb5d07fc4810299a6f8af579ebf67ea5cdb4c05667fd7f423b64173e93386186971361be0fc56e6377e9266d755482e')
+sha512sums=('7afb26c2448a36e550211878d5e60863dbfd9abdecb298985e20984299fb9954cc4e71fd94bdd9e8139cd837e1977fca3408873ee5e8223874d7048d9813a305')
build() {
cargo build --release --locked
}
package() {
- install -Dm644 "README.md" "$pkgdir/usr/share/doc/${pkgname}/README.md"
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
cd "./target/release"
install -Dm755 btm "$pkgdir/usr/bin/btm"