summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwcasanova2020-05-25 11:45:23 -0400
committerwcasanova2020-05-25 11:45:23 -0400
commit06240fdcff6f6a59a52d3724e456049567c62cd6 (patch)
tree06b4931695eda5045beecf332c3857eaca9e244f
downloadaur-bottom-git.tar.gz
bottom-git
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20f3159b4de8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bottom-git
+ pkgdesc = Yet another cross-platform graphical process/system monitor
+ pkgver = 0.4.3.791.g3ffa437
+ pkgrel = 1
+ url = https://github.com/ClementTsang/bottom
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ makedepends = git
+ provides = bottom
+ conflicts = bottom
+ conflicts = bottom-bin
+ source = bottom::git+https://github.com/ClementTsang/bottom.git
+ sha256sums = SKIP
+
+pkgname = bottom-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bea50c7eaaeb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Walter <wcasanova at disroot dot org>
+
+pkgname="bottom-git"
+_pkgname="bottom"
+pkgver=0.4.3.791.g3ffa437
+pkgrel=1
+pkgdesc="Yet another cross-platform graphical process/system monitor"
+arch=("i686" "x86_64")
+url="https://github.com/ClementTsang/bottom"
+license=("MIT")
+depends=()
+makedepends=("rust" "cargo" "git")
+provides=("bottom")
+conflicts=("bottom" "bottom-bin")
+source=("$_pkgname::git+https://github.com/ClementTsang/bottom.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ cargo build --release --locked
+}
+
+check() {
+ cd $_pkgname
+ cargo test --release --locked
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 target/release/btm "$pkgdir/usr/bin/btm"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}