summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Wright2022-12-12 10:53:33 +0000
committerJonathan Wright2022-12-12 10:53:33 +0000
commitaa01e41efb92e6dfa230e2d955194dde5811b9ae (patch)
treef2d010a6d79205ab9c696858541a0bb962e9b58b
parentb47893a4b6718e923e8d0589652e6143ecf97d3e (diff)
downloadaur-aa01e41efb92e6dfa230e2d955194dde5811b9ae.tar.gz
Sync the Makefile updates
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 3721b908155b..a8e5348c6bdc 100644
--- a/Makefile
+++ b/Makefile
@@ -23,7 +23,7 @@ ifdef ($(string $(pkgrel)),)
use_pkgrel=$(pkgrel)
else
ifeq ($(pkgver),$(current_pkgver))
- use_pkgrel=$(current_pkgrel)+1
+ use_pkgrel=$(shell expr $(current_pkgrel) + 1)
else
use_pkgrel=1
endif
@@ -36,7 +36,7 @@ help: ## Show this help message
.PHONY: clean
clean: ## Clean the current workspace
@echo -e "${CC_YELLOW}==>${CC_WHITE} Cleaning up old package files${CC_END}"
- rm -f *.pkg.tar.{xz,zst} *.zip{,.part}
+ rm -rf *.pkg.tar.{xz,zst} *.{zip,gz,xz,zst}{,.part}
@echo -e "${CC_YELLOW}==>${CC_WHITE} Cleaning up old working directories${CC_END}"
rm -rf ./pkg ./src