summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2022-09-06 12:02:37 +0300
committerAdrian Perez de Castro2022-09-06 12:02:37 +0300
commitbe014d0abe991a794fac6ca5c0a71d5e3b325111 (patch)
tree3fc890d3328e4253c46bdb4e11e79e7484286bb2
parentfee4d99ccd39f2f4946a2e0c3918927cd6ea71d3 (diff)
downloadaur-be014d0abe991a794fac6ca5c0a71d5e3b325111.tar.gz
Bump to version 1.0, cleanup PKGBUILKD a bit
While doing the update, also: - Apply patch in the prepare() function, as recommended in the Arch PKGBUILD guidelines. - Add the patch to the "sources" array, in order to support building the package in a clean chroot. - Add the "!lto" option, which is neeeded at least to successfully link on x86_64 in case an user has the option enabled in their "makepkg.conf" file. - Switch to BLAKE2b checksums. MD5 has been broken years ago. - Explicitly set a name for the downloaded tarball.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ca626289376..19da618734e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bower-mail
pkgdesc = A curses terminal client for the Notmuch email system
- pkgver = 0.13
+ pkgver = 1.0
pkgrel = 1
url = https://github.com/wangp/bower
arch = any
@@ -16,7 +16,10 @@ pkgbase = bower-mail
optdepends = lynx: dump HTML emails
optdepends = w3m: dump HTML emails
conflicts = bower
- source = https://github.com/wangp/bower/archive/0.13.tar.gz
- md5sums = f4687f241fdeb948cafb1ed246ec14fb
+ options = !lto
+ source = bower-1.0.tar.gz::https://github.com/wangp/bower/archive/1.0.tar.gz
+ source = arch.patch
+ b2sums = 344533608ce33ce3dc011916045297d36f17b6c51e22261e831e2063bebf0cc73d5d464cc65edc92528384e97a3a8d338212f2371d84a08bb76d3aaa3f5a9a35
+ b2sums = 20f10c1d6e7516f91ca4baee45f833da7844870a94ec4f7b4f3a0f8b31ba43e143fd9589de9b12cd02e420ea50a1407b2e5ec796de253108ab7e8cd38dbbf103
pkgname = bower-mail
diff --git a/PKGBUILD b/PKGBUILD
index 136419a28786..730b87d4e496 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
-# Maintainer: Frank Seifferth <frankseifferth@posteo.net>
+# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
+# Contributor: Frank Seifferth <frankseifferth@posteo.net>
pkgname=bower-mail
-pkgver=0.13
+pkgver=1.0
pkgrel=1
pkgdesc="A curses terminal client for the Notmuch email system"
arch=('any')
url="https://github.com/wangp/bower"
depends=('notmuch' 'ncurses' 'coreutils' 'file' 'mercury>=14.04')
makedepends=('gpgme' 'pandoc')
+options=(!lto)
optdepends=('msmtp: send messages' 'lynx: dump HTML emails' 'w3m: dump HTML emails')
conflicts=('bower')
license=('GPL3')
-source=("https://github.com/wangp/bower/archive/$pkgver.tar.gz")
-md5sums=('f4687f241fdeb948cafb1ed246ec14fb')
+source=("bower-$pkgver.tar.gz::https://github.com/wangp/bower/archive/$pkgver.tar.gz" arch.patch)
+b2sums=('344533608ce33ce3dc011916045297d36f17b6c51e22261e831e2063bebf0cc73d5d464cc65edc92528384e97a3a8d338212f2371d84a08bb76d3aaa3f5a9a35'
+ '20f10c1d6e7516f91ca4baee45f833da7844870a94ec4f7b4f3a0f8b31ba43e143fd9589de9b12cd02e420ea50a1407b2e5ec796de253108ab7e8cd38dbbf103')
+
+prepare () {
+ patch "$srcdir/bower-$pkgver/src/Mercury.options" < "$srcdir/arch.patch"
+}
build() {
- patch "$srcdir/bower-$pkgver/src/Mercury.options" < ../arch.patch
cd "$srcdir/bower-$pkgver"
make PARALLEL=$MAKEFLAGS
make man