summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorber532k2017-07-29 22:56:50 +0200
committerber532k2017-07-29 22:56:50 +0200
commitd58a8e19db118c34662e8552f05fcd97c7a47e00 (patch)
tree50f7ee01f9733c58ebe2a0e51344062f5efe8955
downloadaur-d58a8e19db118c34662e8552f05fcd97c7a47e00.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD25
-rw-r--r--arch.patch11
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ba63d129769
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = bower-mail
+ pkgdesc = A curses terminal client for the Notmuch email system
+ pkgver = 0.7
+ pkgrel = 1
+ url = https://github.com/wangp/bower
+ arch = any
+ license = GPL3
+ makedepends = gpgme
+ depends = notmuch
+ depends = ncurses
+ depends = coreutils
+ depends = file
+ depends = mercury>=11.07
+ optdepends = msmtp: send messages
+ optdepends = lynx: dump HTML emails
+ optdepends = w3m: dump HTML emails
+ conflicts = bower
+ source = https://github.com/wangp/bower/archive/0.7.tar.gz
+ md5sums = SKIP
+
+pkgname = bower-mail
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73fd150800fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: ber532k <ber532k@gmx.de>
+pkgname=bower-mail
+pkgver=0.7
+pkgrel=1
+pkgdesc="A curses terminal client for the Notmuch email system"
+arch=('any')
+url="https://github.com/wangp/bower"
+depends=('notmuch' 'ncurses' 'coreutils' 'file' 'mercury>=11.07')
+makedepends=('gpgme')
+optdepends=('msmtp: send messages' 'lynx: dump HTML emails' 'w3m: dump HTML emails')
+conflicts=('bower')
+license=('GPL3')
+source=("https://github.com/wangp/bower/archive/$pkgver.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ patch $srcdir/bower-$pkgver/src/Mercury.options < ../arch.patch
+ cd $srcdir/bower-$pkgver
+ make PARALLEL=$MAKEFLAGS
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ install -m 755 $srcdir/bower-$pkgver/bower $pkgdir/usr/bin/
+}
diff --git a/arch.patch b/arch.patch
new file mode 100644
index 000000000000..555733386a9f
--- /dev/null
+++ b/arch.patch
@@ -0,0 +1,11 @@
+--- src/bower-0.7/src/Mercury.options 2016-03-28 02:10:09.000000000 +0200
++++ patched 2017-07-29 14:05:18.286657586 +0200
+@@ -9,7 +9,7 @@
+ MLLIBS-bower += -lgpgme
+
+ # Statically link to Mercury libraries.
+-MCFLAGS-bower += --mercury-linkage static
++#MCFLAGS-bower += --mercury-linkage static
+
+ # General optimisation flags.
+ MCFLAGS += --optimise-constructor-last-call