summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212021-12-26 11:24:56 +0100
committera8212021-12-26 11:24:56 +0100
commit8f9b1770ae638de398f55ac78764c39aa7600dc8 (patch)
treed611e98efdc2a593d7bfcf530b4eb4278fb87249
parentf480efc70a61b923e9ac067605c03b3743232d1f (diff)
downloadaur-8f9b1770ae638de398f55ac78764c39aa7600dc8.tar.gz
Version 1.3.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
-rw-r--r--makefile_uname.patch11
3 files changed, 22 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c976912c35d5..37b0e9589f0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = bowtie
- pkgdesc = Bowtie is an alignment tool for short nucleotide sequences against long templates
- pkgver = 1.2.3
+ pkgdesc = Alignment tool for short nucleotide sequences against long templates
+ pkgver = 1.3.1
pkgrel = 1
- url = http://bowtie-bio.sf.net
+ url = https://bowtie-bio.sf.net
arch = x86_64
arch = i686
- license = PerlArtistic
- source = https://github.com/BenLangmead/bowtie/archive/v1.2.3.tar.gz
- source = makefile_uname.patch
- sha256sums = 86402114caeacbb3a3030509cb59f0b7e96361c7b3ee2dd50e2cd68200898823
- sha256sums = 6b77e333a3ef10e3f787fd2983afd69cdb48e82347fc3316510c2ba5639742a3
+ license = Artistic2.0
+ depends = python
+ depends = perl
+ source = bowtie-1.3.1.tar.gz::https://github.com/BenLangmead/bowtie/archive/v1.3.1.tar.gz
+ sha256sums = 147d9fe9652f7c5f351bfc0eb012e06981986fb43bd6bdfe88a95c02eabc6573
pkgname = bowtie
-
diff --git a/PKGBUILD b/PKGBUILD
index 25a0c7d8b275..2c48e2593d08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,29 @@
-# Maintainer: Athemis <alexander.minges[at]googlemail[dot]com>
+# Maintainer: a821
+# Contributor: Athemis <alexander.minges[at]googlemail[dot]com>
# Contributor: sauliusl
+
pkgname=bowtie
-pkgver=1.2.3
+pkgver=1.3.1
pkgrel=1
-pkgdesc="Bowtie is an alignment tool for short nucleotide sequences against long templates"
-url="http://bowtie-bio.sf.net"
+pkgdesc="Alignment tool for short nucleotide sequences against long templates"
+url="https://bowtie-bio.sf.net"
arch=('x86_64' 'i686')
-license=('PerlArtistic')
-depends=()
-source=("https://github.com/BenLangmead/bowtie/archive/v${pkgver}.tar.gz"
- "makefile_uname.patch")
-sha256sums=('86402114caeacbb3a3030509cb59f0b7e96361c7b3ee2dd50e2cd68200898823'
- '6b77e333a3ef10e3f787fd2983afd69cdb48e82347fc3316510c2ba5639742a3')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np0 -i ../makefile_uname.patch
-}
+license=('Artistic2.0')
+depends=('python' 'perl')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/BenLangmead/bowtie/archive/v${pkgver}.tar.gz")
+sha256sums=('147d9fe9652f7c5f351bfc0eb012e06981986fb43bd6bdfe88a95c02eabc6573')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- make NO_TBB=1 EXTRA_CXXFLAGS="-std=c++03"
+ make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make prefix=/usr DESTDIR="${pkgdir}" install
- install -d ${pkgdir}/usr/share/doc/${pkgname}
- install -Dm755 scripts/*.pl "${pkgdir}/usr/bin"
- install -Dm755 scripts/*.sh "${pkgdir}/usr/bin"
- find doc -type f -exec install -Dm644 "{}" "${pkgdir}/usr/share/doc/${pkgname}" \;
- install -Dm644 TUTORIAL "${pkgdir}/usr/share/doc/$pkgname/TUTORIAL"
- install -Dm644 MANUAL "$pkgdir/usr/share/doc/$pkgname/MANUAL"
- install -Dm644 MANUAL.markdown "$pkgdir/usr/share/doc/$pkgname/MANUAL.markdown"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ install -Dm755 -t "${pkgdir}/usr/share/${pkgname}/scripts/" scripts/*.{pl,sh}
+ install -Dm644 -t "${pkgdir}/usr/share/doc/$pkgname/" MANUAL{,.markdown} TUTORIAL AUTHORS NEWS
}
# vim:set ts=2 sw=2 et:
diff --git a/makefile_uname.patch b/makefile_uname.patch
deleted file mode 100644
index b9833cd6d4db..000000000000
--- a/makefile_uname.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile 2013-04-18 21:33:44.000000000 +0200
-+++ Makefile 2013-06-26 16:25:17.622402991 +0200
-@@ -107,7 +107,7 @@
- endif
-
- ifeq (1,$(LINUX))
-- ifeq (x86_64, $(shell uname -p))
-+ ifeq (x86_64, $(shell uname -m))
- BITS=64
- endif
- endif