summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Minges2018-01-05 01:09:03 +0100
committerAlexander Minges2018-01-05 01:09:03 +0100
commitff731414cb44c3014c747414eeb18719e9d65f79 (patch)
tree28c77c45fb2b7d9a78c1b6bd0e6b67a750991e1d
parentc172972f885a745ae7ac1f7c0817fce0e8d5a972 (diff)
downloadaur-ff731414cb44c3014c747414eeb18719e9d65f79.tar.gz
version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2ca03b295fb..4acaac656169 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Jan 5 00:08:52 UTC 2018
pkgbase = bowtie
pkgdesc = Bowtie is an alignment tool for short nucleotide sequences against long templates
- pkgver = 1.1.2
+ pkgver = 1.2.2
pkgrel = 1
url = http://bowtie-bio.sf.net
arch = x86_64
arch = i686
license = PerlArtistic
- source = http://downloads.sourceforge.net/bowtie-bio/bowtie-1.1.2-src.zip
+ source = https://github.com/BenLangmead/bowtie/archive/v1.2.2_p1.tar.gz
source = makefile_uname.patch
- sha256sums = b1e9ccc825207efd1893d9e33244c681bcb89b9b2b811eb95a9f5a92eab637ae
+ sha256sums = e1b02b2e77a0d44a3dd411209fa1f44f0c4ee304ef5cc83f098275085740d5a1
sha256sums = 6b77e333a3ef10e3f787fd2983afd69cdb48e82347fc3316510c2ba5639742a3
pkgname = bowtie
diff --git a/PKGBUILD b/PKGBUILD
index 2d14274101bf..55be30cf451a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,30 @@
# Maintainer: Athemis <alexander.minges[at]googlemail[dot]com>
# Contributor: sauliusl
pkgname=bowtie
-pkgver=1.1.2
+pkgver=1.2.2
pkgrel=1
pkgdesc="Bowtie is an alignment tool for short nucleotide sequences against long templates"
url="http://bowtie-bio.sf.net"
arch=('x86_64' 'i686')
license=('PerlArtistic')
depends=()
-source=("http://downloads.sourceforge.net/bowtie-bio/${pkgname}-${pkgver}-src.zip"
+source=("https://github.com/BenLangmead/bowtie/archive/v${pkgver}_p1.tar.gz"
"makefile_uname.patch")
-sha256sums=('b1e9ccc825207efd1893d9e33244c681bcb89b9b2b811eb95a9f5a92eab637ae'
+sha256sums=('e1b02b2e77a0d44a3dd411209fa1f44f0c4ee304ef5cc83f098275085740d5a1'
'6b77e333a3ef10e3f787fd2983afd69cdb48e82347fc3316510c2ba5639742a3')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}_p1"
patch -Np0 -i ../makefile_uname.patch
- make
+ make NO_TBB=1 EXTRA_CXXFLAGS="-std=c++03"
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- install -d ${pkgdir}/usr/bin
+ cd "${srcdir}/${pkgname}-${pkgver}_p1"
+ make prefix=/usr DESTDIR="${pkgdir}" install
install -d ${pkgdir}/usr/share/doc/${pkgname}
- install -Dm755 bowtie ${pkgdir}/usr/bin
- install -Dm755 bowtie-build* ${pkgdir}/usr/bin
- install -Dm755 bowtie-inspect* ${pkgdir}/usr/bin
- install -Dm755 bowtie-align* ${pkgdir}/usr/bin
- install -Dm755 scripts/* ${pkgdir}/usr/bin
- install -Dm644 doc/* ${pkgdir}/usr/share/doc/${pkgname}
- install -Dm644 TUTORIAL "${pkgdir}/usr/share/doc/${pkgname}/TUTORIAL"
+ find doc -type f -exec install -Dm644 "{}" "${pkgdir}/usr/share/doc/${pkgname}" \;
+ install -Dm644 TUTORIAL "${pkgdir}/usr/share/doc/$pkgname/TUTORIAL"
install -Dm644 MANUAL "$pkgdir/usr/share/doc/$pkgname/MANUAL"
install -Dm644 MANUAL.markdown "$pkgdir/usr/share/doc/$pkgname/MANUAL.markdown"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"