summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-05-10 13:41:59 +0100
committerGrey Christoforo2016-05-10 13:41:59 +0100
commit413591a7b1b8222e5b8d1cfd53e3149aedca2f54 (patch)
tree92097d81f1328d3503c88e42699db1d060c25ca0
parentbe1060a66fd9f2681d766668e835196ae4cf9e5a (diff)
downloadaur-413591a7b1b8222e5b8d1cfd53e3149aedca2f54.tar.gz
bump to 2.2.9
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD14
3 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cca9465a09ca..22357abb63b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
# Generated by mksrcinfo v8
-# Sun Mar 13 20:06:50 UTC 2016
+# Tue May 10 12:41:25 UTC 2016
pkgbase = bowtie2
pkgdesc = Bowtie 2 is an ultrafast and memory-efficient tool for aligning sequencing reads to long reference sequence.
- pkgver = 2.2.8
+ pkgver = 2.2.9
pkgrel = 1
url = http://bowtie-bio.sourceforge.net/bowtie2
arch = any
license = GPL3
optdepends = intel-tbb: faster multithreading
- source = https://github.com/BenLangmead/bowtie2/archive/v2.2.8.tar.gz
- md5sums = 42948ac7744d691a7a643ed94a36ed63
+ source = https://github.com/BenLangmead/bowtie2/archive/v2.2.9.tar.gz
+ md5sums = 168bdcd6a648e96d8a9a854cdbae24d8
pkgname = bowtie2
diff --git a/.gitignore b/.gitignore
index 32f0ae164510..922dfb2216fd 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ src/
pkg/
*.tar.gz
*.tar.xz
+*.tar
diff --git a/PKGBUILD b/PKGBUILD
index 0c815625860d..934c4dc4e2aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=bowtie2
-pkgver=2.2.8
+pkgver=2.2.9
pkgrel=1
pkgdesc="Bowtie 2 is an ultrafast and memory-efficient tool for aligning sequencing reads to long reference sequence."
arch=("any")
@@ -10,7 +10,7 @@ optdepends=('intel-tbb: faster multithreading')
url="http://bowtie-bio.sourceforge.net/bowtie2"
license=('GPL3')
source=("https://github.com/BenLangmead/${pkgname}/archive/v${pkgver}.tar.gz")
-md5sums=('42948ac7744d691a7a643ed94a36ed63')
+md5sums=('168bdcd6a648e96d8a9a854cdbae24d8')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -20,13 +20,13 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
if pacman -Q intel-tbb > /dev/null 2>/dev/null; then
- msg2 "Building with Intel's TBB multithreading support"
- #WITH_TBB=1 make
+ #msg2 "Building with Intel's TBB multithreading support"
+ #WITH_TBB=1 make prefix=/usr
# tbb is broken in this release...remove this when fixed
- WITH_TBB=0 make
+ WITH_TBB=0 make
else
msg2 "You haven't installed the intel-tbb package; building without Intel's TBB multithreading support"
- WITH_TBB=0 make
+ WITH_TBB=0 make
fi
}
@@ -34,7 +34,7 @@ package() {
mkdir -p "${pkgdir}/opt/${pkgname}"
cp -a "${srcdir}/${pkgname}-${pkgver}"/* "${pkgdir}/opt/${pkgname}"/.
cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ make prefix=/usr DESTDIR="${pkgdir}" install
install -Dm644 ${srcdir}/${pkgname}-${pkgver}/MANUAL -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dm644 ${srcdir}/${pkgname}-${pkgver}/LICENSE -t "$pkgdir/usr/share/licenses/${pkgname}"
}