summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2017-04-17 12:47:14 +0100
committerGrey Christoforo2017-04-17 12:47:14 +0100
commit7f5eb5b5256c4a86b28ae501e45bf39d64a140a1 (patch)
tree637e7ed7010d2eccb434512900092317843d5d8d
parent1ab892ea5a1a9ab6dd8499868b46ad2108ce99ff (diff)
downloadaur-7f5eb5b5256c4a86b28ae501e45bf39d64a140a1.tar.gz
fix for tbb build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91470577d6a6..808672160d9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Mar 11 14:03:13 UTC 2017
+# Mon Apr 17 11:47:10 UTC 2017
pkgbase = bowtie2
pkgdesc = Bowtie 2 is an ultrafast and memory-efficient tool for aligning sequencing reads to long reference sequence.
pkgver = 2.3.1
- pkgrel = 1
+ pkgrel = 2
url = http://bowtie-bio.sourceforge.net/bowtie2
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 9540e89f3be6..c135c6b81c56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=bowtie2
pkgver=2.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Bowtie 2 is an ultrafast and memory-efficient tool for aligning sequencing reads to long reference sequence."
arch=("any")
depends=('termcap')
@@ -21,13 +21,11 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
if pacman -Q intel-tbb > /dev/null 2>/dev/null; then
- #msg2 "Building with Intel's TBB multithreading support"
- #WITH_TBB=1 make prefix=/usr
- # tbb is _STILL_ broken in this release...remove this when fixed
- NO_TBB=1 make prefix=/usr
+ msg2 "Building with Intel's TBB multithreading support"
+ EXTRA_FLAGS="-std=gnu++98" NO_TBB=0 make prefix=/usr
else
msg2 "You haven't installed the intel-tbb package; building without Intel's TBB multithreading support"
- NO_TBB=1 make
+ EXTRA_FLAGS="-std=gnu++98" NO_TBB=1 make prefix=/usr
fi
}