summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-01-19 12:40:29 +0000
committerGrey Christoforo2016-01-19 12:40:29 +0000
commit9755538380e2ffc2218da436961c8d0dd58ccd2e (patch)
tree76f9fc0c9b0c514b5f4609a613610bcd53070592
parent3a018e6cd37b9e831d830b1861be4bcb41e5445f (diff)
downloadaur-9755538380e2ffc2218da436961c8d0dd58ccd2e.tar.gz
install scripts and examples
-rw-r--r--PKGBUILD30
1 files changed, 19 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da11fa232ceb..ff0491bc8019 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,37 @@
-# Maintainer: Grey Christoforo <grey@christoforo.net>
-# Contributer: Thiago Yukio Kikuchi Oliveira <stratust@gmail.com>
-# Contributer: Decrypted Epsilon <decrypted.epsilon (at) gmail (dot) com>
+# $Id$
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=bowtie2
pkgver=2.2.6
pkgrel=4
pkgdesc="Bowtie 2 is an ultrafast and memory-efficient tool for aligning sequencing reads to long reference sequence."
arch=("any")
+optdepends=('intel-tbb: faster multithreading')
url="http://bowtie-bio.sourceforge.net/bowtie2"
license=('GPL3')
source=("https://github.com/BenLangmead/${pkgname}/archive/v${pkgver}.tar.gz")
-
+md5sums=('9e5d10dff2424177e8051092ff502bb6')
build() {
cd $srcdir/$pkgname-$pkgver
- make clean
- make
+ if pacman -Q intel-tbb > /dev/null 2>/dev/null; then
+ msg2 "Building with Intel's TBB multithreading support"
+ #WITH_TBB=1 make
+ # tbb is broken in this release...remove this when fixed
+ WITH_TBB=0 make
+ else
+ msg2 "You haven't installed the intel-tbb package; building without Intel's TBB multithreading support"
+ WITH_TBB=0 make
+ fi
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
- install -d ${pkgdir}/usr/share/doc/${pkgname}
- install -Dm644 doc/* ${pkgdir}/usr/share/doc/${pkgname}
- install -Dm644 MANUAL "${pkgdir}/usr/share/doc/${pkgname}/MANUAL"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ mkdir -p ${pkgdir}/usr/share/doc/${pkgname}
+ cp -a doc/* ${pkgdir}/usr/share/doc/${pkgname}/.
+ cp -a example ${pkgdir}/usr/share/doc/${pkgname}
+ cp -a scripts ${pkgdir}/usr/share/doc/${pkgname}
+ install -Dm644 ${srcdir}/${pkgname}-${pkgver}/MANUAL -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm644 ${srcdir}/${pkgname}-${pkgver}/LICENSE -t "$pkgdir/usr/share/licenses/${pkgname}"
}
-md5sums=('9e5d10dff2424177e8051092ff502bb6')