summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvejnar2021-07-12 11:39:33 -0400
committervejnar2021-07-12 11:39:33 -0400
commitc6181d33f0c08fb8ba8a5801f31c5ee8d937931e (patch)
tree007bfcf4ce570c09532f8e4b43903c148a92b1d1
parent67eaf3b7b937d99c7730f9c7b099027f37595935 (diff)
downloadaur-c6181d33f0c08fb8ba8a5801f31c5ee8d937931e.tar.gz
Update to 2.4.4 and fixes
* Remove TBB (no longer supported upstream) * Remove termcap dependency * Switch arch to x86_64 * Fix install (prefix to PREFIX; no /opt copy)
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD39
2 files changed, 19 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6146c305a162..5d604c3e003b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,11 @@
pkgbase = bowtie2
pkgdesc = Bowtie 2 is an ultrafast and memory-efficient tool for aligning sequencing reads to long reference sequence.
- pkgver = 2.4.2
+ pkgver = 2.4.4
pkgrel = 1
url = http://bowtie-bio.sourceforge.net/bowtie2
- arch = any
+ arch = x86_64
license = GPL3
- depends = termcap
- optdepends = intel-tbb: faster multithreading
- source = https://github.com/BenLangmead/bowtie2/archive/v2.4.2.tar.gz
- md5sums = d5f8674aed8bdbf6b96bd07f3df528ee
+ source = https://github.com/BenLangmead/bowtie2/archive/v2.4.4.tar.gz
+ sha1sums = cf23a10261d0ef4b7a993ef562d5ccd4410e7dd6
pkgname = bowtie2
-
diff --git a/PKGBUILD b/PKGBUILD
index 0c1276ecf16d..39987d8200c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,31 @@
# $Id$
-# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+# Maintainer: Charles Vejnar <first name [dot] last name [at] gmail [dot] com>
+# Contributor: Grey Christoforo <first name [at] last name [dot] net>
pkgname=bowtie2
-pkgver=2.4.2
+pkgver=2.4.4
pkgrel=1
pkgdesc="Bowtie 2 is an ultrafast and memory-efficient tool for aligning sequencing reads to long reference sequence."
-arch=("any")
-depends=('termcap')
-optdepends=('intel-tbb: faster multithreading')
+arch=("x86_64")
url="http://bowtie-bio.sourceforge.net/bowtie2"
-license=(GPL3)
+license=("GPL3")
source=("https://github.com/BenLangmead/bowtie2/archive/v${pkgver}.tar.gz")
-md5sums=('d5f8674aed8bdbf6b96bd07f3df528ee')
+sha1sums=('cf23a10261d0ef4b7a993ef562d5ccd4410e7dd6')
prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make clean
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make clean
}
build() {
- cd "bowtie2-${pkgver}"
- if pacman -Q intel-tbb > /dev/null 2>/dev/null; then
- msg2 "Building with Intel's TBB multithreading support"
- EXTRA_FLAGS="-std=gnu++98" NO_TBB=0 make prefix=/usr
- else
- msg2 "You haven't installed the intel-tbb package; building without Intel's TBB multithreading support"
- EXTRA_FLAGS="-std=gnu++98" NO_TBB=1 make prefix=/usr
- fi
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make PREFIX=/usr
}
package() {
- mkdir -p "${pkgdir}/opt/"
- cp -a "${srcdir}/bowtie2-${pkgver}" "${pkgdir}/opt/bowtie2"
- cd "${srcdir}/bowtie2-${pkgver}"
- make prefix=/usr DESTDIR="${pkgdir}" install
- mkdir -p "${pkgdir}/usr/share/doc/bowtie2"
- cp -a ${srcdir}/bowtie2-${pkgver}/doc "${pkgdir}/usr/share/doc/bowtie2"
- install -Dm644 ${srcdir}/bowtie2-${pkgver}/LICENSE -t "${pkgdir}/usr/share/licenses/bowtie2"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}"
+ cp -a "${srcdir}/bowtie2-${pkgver}/doc" "${pkgdir}/usr/share/doc/${pkgname}"
}