summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2015-08-03 10:39:29 +0200
committerGrey Christoforo2015-08-03 10:39:29 +0200
commitc7205e0bd9ff7e1fd54fcdf01f5e519218f980e4 (patch)
tree03d5dbd83740d4187bdb334488eb63065ab7cd8b
parent60baf1d6e0163f34ef6a8bb544212486e2503ce6 (diff)
downloadaur-c7205e0bd9ff7e1fd54fcdf01f5e519218f980e4.tar.gz
use make install, update source url
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
2 files changed, 11 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85c23711dd18..40761472828c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = bowtie2
pkgdesc = Bowtie 2 is an ultrafast and memory-efficient tool for aligning sequencing reads to long reference sequence.
pkgver = 2.2.6
- pkgrel = 1
+ pkgrel = 2
url = http://bowtie-bio.sourceforge.net/bowtie2
- arch = x86_64
+ arch = any
license = GPL3
- source = bowtie2-2.2.6-source.zip::https://github.com/BenLangmead/bowtie2/blob/master/latest_release/bowtie2-2.2.6-source.zip?raw=true
+ source = https://github.com/BenLangmead/bowtie2/releases/download/v2.2.6/bowtie2-2.2.6-source.zip
sha512sums = 3ab5a5475cf214affd91e0d1782fd2d6dedccd979e3c809b5dfb272726d99ff1c7b59d92e387b187a7c2e43557786a1085186ccb96588de91212caf2eb94ce4f
pkgname = bowtie2
diff --git a/PKGBUILD b/PKGBUILD
index 9e5d78bbe1a9..c88da3fdace2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,34 +4,24 @@
pkgname=bowtie2
pkgver=2.2.6
-_pkgver=$pkgver
-pkgrel=1
+pkgrel=2
pkgdesc="Bowtie 2 is an ultrafast and memory-efficient tool for aligning sequencing reads to long reference sequence."
-arch=("x86_64")
+arch=("any")
url="http://bowtie-bio.sourceforge.net/bowtie2"
license=('GPL3')
-source=(bowtie2-2.2.6-source.zip::https://github.com/BenLangmead/bowtie2/blob/master/latest_release/bowtie2-2.2.6-source.zip?raw=true)
-#source=(http://downloads.sourceforge.net/project/bowtie-bio/bowtie2/$_pkgver/$pkgname-$_pkgver-source.zip)
+source=("https://github.com/BenLangmead/bowtie2/releases/download/v$pkgver/$pkgname-$pkgver-source.zip")
+#source=(http://downloads.sourceforge.net/project/bowtie-bio/bowtie2/$pkgver/$pkgname-$pkgver-source.zip)
sha512sums=('3ab5a5475cf214affd91e0d1782fd2d6dedccd979e3c809b5dfb272726d99ff1c7b59d92e387b187a7c2e43557786a1085186ccb96588de91212caf2eb94ce4f')
build() {
- cd $srcdir/$pkgname-$_pkgver
+ cd $srcdir/$pkgname-$pkgver
+ make clean
make
}
package() {
- cd "${srcdir}/${pkgname}-${_pkgver}"
- install -d ${pkgdir}/usr/bin
- install -d ${pkgdir}/usr/share/doc/${pkgname}
- install -Dm755 bowtie2 ${pkgdir}/usr/bin
- install -Dm755 bowtie2-align-l ${pkgdir}/usr/bin
- install -Dm755 bowtie2-align-s ${pkgdir}/usr/bin
- install -Dm755 bowtie2-build ${pkgdir}/usr/bin
- install -Dm755 bowtie2-build-l ${pkgdir}/usr/bin
- install -Dm755 bowtie2-build-s ${pkgdir}/usr/bin
- install -Dm755 bowtie2-inspect ${pkgdir}/usr/bin
- install -Dm755 bowtie2-inspect-l ${pkgdir}/usr/bin
- install -Dm755 bowtie2-inspect-s ${pkgdir}/usr/bin
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
install -Dm644 doc/* ${pkgdir}/usr/share/doc/${pkgname}
install -Dm644 MANUAL "${pkgdir}/usr/share/doc/${pkgname}/MANUAL"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"