summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-10-26 14:37:43 +0800
committerChocobo12020-10-26 14:51:11 +0800
commit644b4877c37806ec42556651bcb58cbbbba08043 (patch)
tree3991a855b39e122e0f89509f78821eb3dc59bd54
downloadaur-644b4877c37806ec42556651bcb58cbbbba08043.tar.gz
newpkg: bowtie2-bin 2.4.2-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b07505d8c27
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = bowtie2-bin
+ pkgdesc = Tool for aligning sequencing reads to long reference sequences
+ pkgver = 2.4.2
+ pkgrel = 1
+ url = http://bowtie-bio.sourceforge.net/bowtie2/index.shtml
+ arch = x86_64
+ arch = aarch64
+ license = GPL
+ depends = glibc
+ optdepends = perl
+ optdepends = python
+ provides = bowtie2
+ conflicts = bowtie2
+ source_x86_64 = https://github.com/BenLangmead/bowtie2/releases/download/v2.4.2/bowtie2-2.4.2-linux-x86_64.zip
+ sha256sums_x86_64 = e8e63299320708d0a98b19e48a3b1c32fb3de809d4c2ca6c8f320126deea862e
+ source_aarch64 = https://github.com/BenLangmead/bowtie2/releases/download/v2.4.2/bowtie2-2.4.2-linux-aarch64.zip
+ sha256sums_aarch64 = 64fdd108825738766c5a700036aeebd4ed2db404228538741bdd93476a20fd2a
+
+pkgname = bowtie2-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b833c268d551
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=bowtie2-bin
+pkgver=2.4.2
+pkgrel=1
+pkgdesc="Tool for aligning sequencing reads to long reference sequences"
+arch=('x86_64' 'aarch64')
+url="http://bowtie-bio.sourceforge.net/bowtie2/index.shtml"
+license=('GPL')
+depends=('glibc')
+optdepends=('perl' 'python')
+provides=('bowtie2')
+conflicts=('bowtie2')
+source_x86_64=("https://github.com/BenLangmead/bowtie2/releases/download/v$pkgver/bowtie2-$pkgver-linux-x86_64.zip")
+source_aarch64=("https://github.com/BenLangmead/bowtie2/releases/download/v$pkgver/bowtie2-$pkgver-linux-aarch64.zip")
+sha256sums_x86_64=('e8e63299320708d0a98b19e48a3b1c32fb3de809d4c2ca6c8f320126deea862e')
+sha256sums_aarch64=('64fdd108825738766c5a700036aeebd4ed2db404228538741bdd93476a20fd2a')
+
+
+package() {
+ cd "bowtie2-$pkgver-linux-$CARCH"
+
+ install -Dm755 bowtie2{,-*} -t "$pkgdir/usr/bin"
+ rm "$pkgdir/usr/bin"/*-debug
+
+ install -Dm644 {MANUAL,MANUAL.markdown,TUTORIAL} -t "$pkgdir/usr/share/doc/bowtie2"
+ install -Dm644 "doc"/* -t "$pkgdir/usr/share/doc/bowtie2/doc"
+}